Mybook Home Edition Problem


#1

Hi,

I wonder if somebody could help me. I have 3 WD Hard Drives, 2 are within a year old and another is probably around 2 years old.

I have recently gotten a new TV, which has a USB port. I have plugged all 3 drives in, and all work fine.

Today, i wanted to transfer some files, onto the older Mybook, which is a Home Edition, so i plugged it into my computer.

It did not recognise the drive, tried to tell me it was empty, however i know theres over 400GB of files on it which work fine when plugged into the tv.

Naturally, I tried to search for this problem online, have tried multiple things, and it has gotten to the point where I have almost given up.

I got close, but then i have got the error saying this USB device has malfunctioned. I’m guessing i need a driver or something? I would really appreciate it if anyone could provide some ideas/knows how to solve this problem, as I need to retrieve some of these files, and cannot afford to lose them. 

This drive has been extremely reliable and it would be a shame to accept its time has finished

Thankyou for your help

derelict


#2

I would try to update BOTH the firmware and software on the older drive and then plug it in to the TV again.


#3

How would i go about doing this, if i cannot access the drive?

I do think this is what i need to do, I installed the button manager again, but have had no luck.

I think i need the Mass Storage Device driver, but have been unable to locate this

thankyou for replying by the way :slight_smile:


#4

You’re welcome - but something else just occured to me.

Is the USB cable goodt?  Make sure there are no tears or serious kinks in the cable.

Sometimes that error will come up when there is a break in the USB cable.

If you have another USB cable from a WD drive, try THAT one on the troublesome drive.


#5

I have tested a USB cable from my newer Essential drive, which also works on my mac, and  have also purchased a new cable. I believe the problem is the software needed to run the drive is not on any computer I have, and I cannot get this off the drive.

I tried to install a manager off the WDC website, but I am still unable to view the drive, The computer knows that It is there, but it appears as if it is a brand new drive, since it says it is “Local Disk” And beieves it is unformatted with 0GB on the drive.

However, as mentioned above, I can view all the files on my TV through USB, so I know they are there. I am normally able to fix these issues, but now I am just stumped…

Any other thoughts?

thanks again


#6

Have you tried connecting the drive via a router?


#7

I have not tried this, due to my router not having a USB slot. I think it is just an issue with the driver i have, but do not seem to know how to obtain one :frowning: