MyBook freezes my OSX

Hey all!

I’m in a bad spot. 

Yesterday I was going through files on my 6TB western digital my book hard drive connected to my old iMac running snow leopard. I had been playing many different movie files from my camera in quick time player to categorize them during a couple of days and everything had been fine. But all of a sudden quick time froze and wouldn’t answer so I had to force quit it and then I tried again, then the same thing happened and then Finder and everything froze and I had to force shut off the computer by holding down the power button. Then the same thing happened after I restarted the computer. After each time I have to force off the computer the WD hard drive still has its light on and keep sounding like it’s working hard and I have to pull the power plug from it to make it stop. 

Then I started it again to try to just copy files from it but the drive would freeze OSX again. So I connected it to my old macbook pro and the same thing happened but then I tried to connect it with usb instead of fire wire and it seemed to act normal. Then I replaced the firewire and tested and it seemed to work fine on both computers. So I assumed it was the firewire cable that was causing problems. Since I was a bit shaken I started to do backups of everything from the hard drive and copied a folder of 323 GB during the night. In the morning it had copied everything but 10 GB and had frozen again. So again I connected both to the Macbook Pro and copied over what was missing. Then I tried to copy another folder but it froze again. 

It behaves very irrational in my eyes and I wonder what is wrong and what to do?

When I start the computer without that drive, it acts normally and the same goes for when I connect another external hard drive.

Did a control with disk utility on both the internal and the external drives, and it said they are fine.

I didn’t notice that the hard drive was standing in the sun which was shining through the window behind my iMac and the room was quite warm. Can that be what started all this?

Also I noticed that the folder that I did a backup of, shows different content size on the Macbook pro and on the iMac. And this goes for both the original folder and the backup on the other external drive. Finder says both folders are 301 GB on the Macbook and 323 on the iMac. This freaks me out since this is a very important folder and I can’t loose 22 GB. Anyone who knows why this can be?

I would be extremely grateful for any thoughts on this!


Hi rockyduderino, welcome to the WD community. If Disk Utility test completed successfully it is probable that some of your files are corrupted. I recommend you to verify that you have recovered all of your important files and then format the My Book.

How to test a drive for defects or problems on a Mac

How to partition and format a WD drive on Windows (8.1, 8, 7, Vista, XP) and Mac OSX 

1 Like

Thanks a lot jubei!

I will do that as soon as I have the imoprtant files.

I don’t have them yet cause it keeps freezing randomly when I’m copying files from it.

I tried again now and the first time it let me copy 30 GB before it froze and I had to force-restart the system and the next two times it froze everything instantly when I started copying. It’s like it gets tired…