MyBook Essentials on Windows 7 HP laptop has no drive letter

I have a WD MyBook Essentials model WD10000H1U-00 attached to an HP G60 Notebook running Windows 7 Home Edition that was upgraded from Vista. 

This is a backup drive that is a transplant from my full tower XP computer whose Motherboard took a trip to the Great Computer Junkyard in the Sky (after the WD that I was using for a backup was disconnected).

It shows up in the WD Diagnostics and the Windows Control Panel but NOT in the Windows Explorer among the drive letters, meaning I cannot access the files on it.

I have downloaded all the software from the WD site, checked the MS drivers (there are none newer), tried to update the firmware (no luck there), installed the latest SmartWare (it can’t see the drive, either). No way will this Win7 machine allow me to connect. By the way, the WD drive is not password protected. The WD diagnostics program sees the drive and gives it passing tests, so the drive is live.

How can I get a drive letter operational on this hardware?

Thanks a bunch.

I have the same probelm and I realy need the stuff on the drive.

can you please give a sutibale soulotion?

I have the same problem too.  My OS  is Window 7.  I was working fine for year but few days ago when I connect to it, Window 7 did not show the Drive Letter anymore.

Did you go to disk management and try assigning a letter there? Just right click on the drive.


Thanks a bunch. That worked.

I tried to click the star but nothing happened. I’ll try again.