MyBook Essential-MAC USERS BEWARE!


#1

Unfortunately I bought two 1TB MyBook Essential drives last week. Both constantly hang or freeze whether I attach them to an old G4 iBook, a G5 PowerMac or an intel Mac.

They’re unusable.

I updated the firmware and installed the updated software that’s available on the WD site. I didn’t want to install software just to use a storage device, but I was hoping it would solve the problem

It didn’t.

I’d like to mention that I own a bunch of WD drives…14 to be exact… so I’m not a newbie.

After spending hours trying to get these brand new drives to work properly I’ve given up.

These new MyBook Essential drives with the VCD (which genius came up with that idea?) have serious technical flaws.

BTW: Mac OS X 10.4.11 and Lepard 10.5.8

I’ll also mention that I reformatted both drives to Mac HFS Extended.


#2

Should have checked here first…too late for me, save yourselves, run.


#3

yeah, I feel ripped off by WD!!

Last year I bought like nine WD drives and didn’t expect this from them.

Never again.

My solution was to get some Seagate FreeAgent drives which were 10 bucks cheaper as well.

as far as tech support… they sent me some newbie suggestions like running Disk Utility, reformatting, updating firmware etc. Things that I had explained I had already done in my initial note.

so…then they suggested I try plugging into the wall instead of a surge protected power strip. power up the drive and then plug it into another usb port and/or another computer.

Like I’m sure that’s what I want to deal with to use my drive.

I tried it anyway… it worked the first time and never again.

Haven’t received a reply from them to my last note for two days now.


#4

Hello,

Is it possible you can disable the Virtual CD (VCD)? Since you are not using the software anyway.

Just to see if this will make things go more smoothly,

Use this below to see how to,

Disable VCD Smartware Link

Thanks in advance, :smiley:


#5

thanks for the reply WDude,

I’ve tried with and without the VCD as well as with and without the software.

I have also run the “Smartware” utility as well as Disk Utility and Disk Warrior more than once.

I’ll also mention that all my other drives work normally on any of the three computers I’m using whether the problematic drives are mounted or not.

I had originally ruled out a hardware issue 'cause it’s happening with both drives… but now I’m thinking that since I bought them together that perhaps it was a bad bunch.

Seems unlikely and I’m hoping it’s something that could be fixed with a new firmware update.


#6

Ok, I received a reply from WD support:

“If you are able to take your drive back to the place of purchase we would recommend you do this, otherwise, we have two warranty replacement options available to you, Advance RMA and Standard RMA. Both options are available on our website.”

Bottom line is… if you use a Mac DON’T buy these WD drives.


#7

Did you change the sleep settings in the smartware application for the drive, you don’t have to use the smartware you change the external’s settings in there though.


#8

it’s not a sleep thing that’s happening. The drives just hang for two to five minutes every time I touch them…even when I simply select it to see what’s in it after it has mounted for a second or two.

I’ve done everything…even the ridiculous workarounds that support suggested.

They finally told me to return the drives.

Politely speaking…WD simply dropped the ball with these drives.

Didn’t expect a company like WD to become so inept.

I’ve since bought four drives by two other manufacturers and will never go back to WD again.

I was gonna’ get a second WD Media Player, but I’m so turned off by them now that I’ve found a more expensive one by another company that I’m getting rather than give WD any more of my money.