MyBook essential and Windows 7 boot issues


#1

Hello, I have a MyBook Essential 500GB USB that I bought a couple years ago when all my systems ran Windows XP and I have NEVER even had the slightest issue with it, until Windows 7 rolled around. (Issue also present in Vista)

I ran all of the betas and ALWAYS had an issue where if the MyBook was connected and powered on, Windows would take a ridiculous amount of time to start the USB bus. If the drive was powered off, no problem. Boot times were fine and USB started immediately.

What happens is (with drive connected and on) if I restart the computer, none of the USB devices are useable until about 1-2 minutes after Windows is booted. This a huge problem as I have a USB mouse and it’s useless on the logon screen until Windows starts the USB bus and hence, the MyBook a couple minutes later.

If the MyBook is unplugged or powered off, Windows 7 boots normally and all USB devices function as soon as the logon screen is showed.

What I have to do is power off the MyBook, restart then power it back on if I don’t want a big delay in starting all of my USB devices. This is clearly less then optimal and I’m not going to deal with it. Once Windows has booted and the delay is behind me, the drive functions fine.

It has nothing to do with the BIOS, Legacy USB options, USB boot, etc. This single problem is what kept me from ever upgrading to Vista/7. Now that I have a new system, I’m pretty stuck. None of this was ever a issue with XP.

There’s posts all over the net about issues like this but absolutely no fix whatsoever.

Any ideas or do I have to trash the drive?


#2

Some how I had a feeling there would be no ideas.

All I can do is tear into the device and put the drive into the case and use the existing electronics to attach a smaller WD drive for the purpose of moving large amounts of data between the 6 machines on the network. I wanted the drive working fully because it’s shared over the network and needs to be up as quick and painlessly as possible. Oh well.

thanks anyway

by the way, I have no issues with either of my flash drives or Seagate external HDDs.


#3

I have the same issue. I use a My Book Essential 250 GB to store system images made using Acronis True Image. I only attach the drive once the computures are up and running and then disconnect it once I’ve made a backup/image. When I plug the drive into a USB port it takes a long time (2 iminutes or so) before the drive is recognized and useable. Once it’s up and running all is well. I’ve attached the drive to 2 other computers running Windows 7 and get the same behaviour. When I attached it to a computer running Windows XP the drive is recognized right away.

I have two hard drives for my laptop. One has Windows 7 and the other Windows XP. I get the same performance as described above - with WinXP it is fast, with Win7 it is slow. Clearly not a hardware issue since it is unchanged except for the hard drive. There’s something with Win7 that slows this down.

I have a couple of other WD external hard drives (WD Passport 250 GB and WD MyBook Home Edition 1 TB) and they are recognized right away.  There is something about the Essential Edition and Win7 that causes the delay. Just not sure what.

If I find anything to speed up the process I’ll post back.


#4

I know I’m not alone, and just as the poster above described - exact same issue but ONLY with the Essential versions of the drives. Seems WD could issue a Firmware update for these drives but probably won’t because it isn’t cost effective for them (it’s all about money) to do so with an out-of-production unit.

I have since removed the 500GB (5000AAKB) IDE drive from the casing and put it into the computer case to avoid all this hassle and have been running it that way ever since. I could wait out the delay if it weren’t for Windows 7 not only NOT initializing the drive but every USB device attached to the system. Which means that until Windows 7 gets the drive ready, my USB mouse/KB will not work for about 2 minutes so I can’t even type my password into the login screen unless I shut the drive off or wait it out. It’s rediculous.

I have tried just about everything to speed this up. Disable prefetching, ReadyBOOT tweaks, disable ReadyBOOST and countless hours doing this and that to no avail.(I’m sick of hearing “Disable USB legacy support and USB boot in the BIOS” when clearly, that has nothing at all to do with it.

Windows XP gets the drive up working in seconds and I’d happily scrap Win7 for XP but system drivers don’t exist for my new system and XP.

The problem itself lies within the “Galaxy” controller board used within the Ext. unit. and Windows 7. If I need to transfer a huge file to another system (too big for network xfer) I just plug another IDE drive into the Galaxy controller and move it between the systems and even with another brand drive attahced, still acts funky in Windows 7.

Annoying as all hell as the “portabilty” factor of my once external drive is gone and now I have another drive in my case taking up valuable space and generating more heat.

Not to sound like a pessimist, but I doubt WD is really going to do a thing other than suggest you buy a “newer” one of their products but if you do happen to figure it out, do post it so all Essential owners can use what they paid for with Windows 7.

Thanks