MyBook Essential 2tb failed....yet not?

I’ve had my drive for roughly a year and a half now, and I love the heck out of it. Never had any problems whatsoever. Until 3 days ago, when the video I was watching started jarring on me, eventually freezing. Everything else on my comp was also acting really slow. I leave my computer on all the time, so I figured it was maybe just time for a restart. Just in case, I copied the last two episodes of the show I had been watching to my comp before I restarted. It took incredibly long, roughly 10 minutes for 200mb, but it seemed to be fine. Once the computer was back up, I tried opening other files, they wouldn’t open. I run the quick drive and complete diagnostic check; both fail. 

I was not happy. I have nearly a terabyte of videos on this, and I really did not want to lose them. However, when i went to open the files I had copied to my computer, they worked fine. On a hunch, I tried copying other files from the drive to my comp. Again, it took incredibly long, but again, they worked fine.

Looking around the site, I found that my drive was still under warranty, and I would be able to get a replacement. However, I do not really want to pay for data recover. Since it was still copying, I just figured I could scrounge enough smaller hard drives together from friends/family to copy all the data to before sending it off. 

To make sure there was as little as possible to copy (at the time, I had over a terabye), I started trying to delete my backups (roughly 200gb total). It ran for nearly 24 hours and only got 3/4rd of the way by the time I had gotten back home. A few hours ago, I’m just browsing on my computer, and suddenly the trash dings that it’s done. When at the rate it had been going, it shouldn’t have been done for many more hours. I start checking, and sure enough, the drive is working again. I can open files, it’s copying correctly…but it’s still failing the diagnostic checks.

I still plan to backup all my data, and I’m hoping that it won’t fail on me again before I can.

My main concerns are: What on earth happened?

IS this likely to return? 

And: Even though this was a legitimate problem that I would be hard pressed to believe was a fluke, if I sent this for replacement while it was functioning, or even if I sent it while it was not functioning for me, but it functioned for WD’s techs, would they just return it to me and claim it wasn’t defective?

Thanks in advance for any information/advice.

Something that that you can try that occasionally fixes strange Windows problems is to shut down your computer then unplug from power for about 15 min. It kind of refreshes the BOIS. I’ve seen this problem with drives suddenly slowing and never saw any reason why.


Mmm, first off, I’m on a mac, Macbook Pro late 2007/early 2008 to be precise, still running leopard.

Also, the drive wasn’t just slow. I could have handled that. I literally could not open anything on it. It gave me error messages.

Thank you for your suggestion, though.