MyBook Elite 1GB not mounting after firmware upgrade


#1

Hi can anyone possibly help? This is my third MyBook replaced via the RMA so its very frustrating!!

I’ve received my new drive from WD and plugged it into my MacBook Pro (Snow Leopard 10.6.3). I upgraded the Firmware of the drive to 2.003. Everything went as per WD instructions until i restarted and now the drive no longer mounts on the desktop shows up in Disk Utility. I’ve checked on a PC again it dosen’t mount.

The screen on the front has XXXXXX and 000 GB FREE with a padlock. If i click on the Update firmware App it says no westernd digital drive found.

Can anyone suggest anything?

Thanks

Mike


#2

Problem Solved by re-installing Firmware via a PC.


#3

Hey! 

How did you reinstall the firmware via PC?

I tryed to reinstall via PC but windows did not recognize the Hard Drive like MacOS! :frowning:


#4

sorry, problem solved!


#5

Can you provide more information on how you got windows to recognize it and how to restore its firmware? Windows doesn’t recognize mine. 

I’d also want to keep all data on the drive. Thanks so much!

Edit: Here is how I got it to work. I have the 1 TB MyBook Essential Mac

So windows didn’t show the drive connected under “My Computer” which is why I thought it wasn’t recognized. I downloaded the “firmware updater” which you can find for your specific drive on the support page of wdc.com

So I started the updater, thinking it wouldn’t work, and it took probably around 30 or 45 minutes, but FINALLY it said it had updated. Then I powercycled the device like it told me to, and windows showed it under “My Computer” so all was good. I then plugged it all up to my macbook pro 13" running snow leopard and the drive mounted fine and all of my data was still there and AFAIK 100% okay. 

Phew that was scary. I hope I helped.