MyBook drive attached via USB to WD Live TV has time/date stamp of Dec. 31, 1999


#1

I have a WD MyBook HD attached to a WD Live TV via USB. Any files that I copy to this drive have a date and timestamp of Dec. 31, 1999.

If I leave the WD Live TV on for more than 24 hours, then copy another file the new one has a date of Jan 1, 2000.

So, the question is: Who maintains this timestamp, and how can I copy files to this drive that will have the correct date and time?

Thanks


#2

I thought the wdtv only moves the files and doesn’t write to them.  Could it be the router doesn’t have the time set in it?


#3

Moves the files from where to where?

This may be where my confusion sets in.

I have a file on my PC that has a timestamp of Aug. 12, 2009

The PC currently believes it is Dec. 18, 2009.

I copy the file to the WD TV Live attached storage.

The file appears on this shared device with a timestamp of Dec. 31, 1999 (yes 1999).

If I wait and copy the file tomorrow the timestamp will be Jan. 1, 2000.

I would have thought that my PC clock would get involved, or the WD TV Live would have a clock.

Perhaps I should copy the files to the drive when it is attached to my PC, then connect the drive to the WD TV Live?

Thanks for any suggestions on this!


#4

This sounds like something you might have to ask wd’s tech support about.  I only play my movies with my wdtv live, so i haven’t had the issues.  Or at least I haven’t noticed. 


#5

Well I do thank you for your ideas or suggestions. 

I just use the timestamp to let me know what movies are the newer versions - I guess if the timestamp is newer then it is the newer movie regardless if the time itself is correct. (silly of me! :slight_smile:

Thanks again for reading and replying to my questions.


#6

I have, what sounds like the same problem. When I copy files from the PC over the network to the WDTV, they show up with the proper time. However, when I modify files over the network using the PC, they are given the bogus time stamp (~2000).

It sounds to me as if the WDTV has a system time of its own, but there’s no way to set it!

This follows the general pattern, that the device firmware has a long way to go before its “done”. I sure hope the WD folks have the attention span to pursue the firmware until it really does work well.


#7

Your description fits exactly what I am seeing.

My WD Live TV developed another problem, play _any_ media file and then I cannot play another without resetting to factory defaults AND cycling the power. I have an RMA on it and hope to have the new one in place soon.

I do hope they get some of these minor bugs fixed. This seems like a very nice device if it only worked.

I have an old Elgato eyeTV that doesn’t play some video container formats (mkv for example), nor does it have HDMI connection, nor is it supported by Elgato anymore, however I tested it by having it play a collection of videos in a loop for the entire month of Dec. and it did just fine. I would like to see the WD Live TV do this!


#8

Same problem here, all files/folders copied over the network to the USB-drive show up with the timestamp 01.01.2000.

This bug is known to WD as the release notes for firmware 1_01_11mention it:

"Resolved issue of time-stamping files to “1/1/2000”; now timestamps are untouched by the WDTV 

Live HD Media Player"

Sounds great, but I am on firmware 1.02.21 now and still the same bug, so what’s going on ?

Suggestions anyone ?


#9

SAme problem, files copied to the HD get 2000 time stamp. it did not work like this before… Windows Xp. i guess its the WD


#10

I have a same problem with the version firmware 1.02.21.

I have made a batch file to synchronize my computer directory of videos with the directory on USB drive connected to the WD live. I make de copy with robocopy with a usb drive accessible on network.

ROBOCOPY “%SourceDirectory%” “%DestinationDirectory%” /MIR  /w:0 /r:0  /Z /FFT