My wdbvht0060jch wont lety me in

I have a wdbvht0060jch for a couple of years now and recently we have had a few power failures and I noticed my access has been getting slow and now the LED stay yellow after booting blue and I can not access anything. I was able to access a few days ago and the data was there just super slow. Has the actual Nas gone bad, the drives appear intact? what can I do? Is there a way I can take the drives out and place them in another case preferable a USB instead of a wireless setup. I have tried to plug it directly into my computer as the manual say but nothing happens>


Have you tried accessing the User interface of the drive using the IP address of the unit?

Also, you can try resetting the unit using the reset button on the back of the unit.

yes I tried both. The indicator light does not change to green so it never links with the network. I tried plugging directly into my computer as well and the drive does not fully load apparently so I can not access it this way either.