My Solution to My Cloud is disconnecting from the Network and disappears when connecting USB hdd

First problem:

Took forever like 30 minutes before the white light changed over to the blue light. Then the device was unresponsive. At first I can SSH into the device, but then after a few minutes, all connections dropped including my SSH. When I tried to Web connect/UI to the device, very slow and eventually unresponsive.

2nd problem:

Connecting an external HDD to the Cloud device immediately causes a lot of thrasing on the new drive causing both the cloud device to disconnect.


SSH to the device just after it boots up and by using

killall wddispatcher

killall wdnotifier

The device works normally after these two commands.

If I simply shutdown the device and plug it in again, the device becomes unresponsive. I do not want to restore it back to OEM as 3.5TB of data takes a long time to copy.

This definitely needs a fix, especially with your next update.

I’ve been a long time user of the WD Live 2TB product and recently and finally got the device to sleep by following some of the instructions from the forums. This was the turning point for me as I discovered this tiny world of linux running on a $150 NAS.

Loving the concept of  the tiny linux running in the WD Live, I decided to stay with the Western Digital Products and bougt the 4TB WD Cloud as well as a WD 4TB My Book so the two can interconnect via the USB 3.0 port.

It took a couple of days to upload 3.5TB of photos (I’m a photographer) which works out to something like a few million photos (I kid you not). Although I use the cloud sharing app, I have no need of seeing tiny sizes of my photos and this was the problem with my WD Live trying to index them all. So I have created a couple of scripts that turns off some of the services and this seems to be working unless you can indicate that it would be a problem.

/etc/init.d/nfs-kernel-server stop

/etc/init.d/nfs-common stop

/etc/init.d/upnp_nas stop

/etc/init.d/mDNSResponder stop

/etc/init.d/wdphotodbmergerd stop

/etc/init.d/wdmcserverd stop

You really need an option on the UI menu to turn off wdmcserverd and wdphotodbmergerd as I do not need indexing. Without these services, I still am able to use the WDCloud app without a tiny photo showing up, but that is fine.

1 Like

so I noticed that in order for the WD Cloud to recognize my WD 4tb My Book the two services needs to be running.

so after killing the two services and letting everything settle down as well as stopping the wdphotodbmergerd and wdmcserverd services because they thrash the two processors trying to index my millions of photos.

/etc/init.d/wdphotodbmergerd stop

/etc/init.d/wdmcserverd stop

I then restarted the two services by stopping and starting them

/etc/init.d/wdnotifierd stop

/etc/init.d/wddispatcherd stop

/etc/init.d/wdnotifierd start

/etc/init.d/wddispatcherd start

This seems to normalize everything…

So I thought I would post up on how I got into this mess and prior to posting up the solution, I had no idea that everyone was having the same problems; perhaps they are related.

When I bought these two devices the 4TB Cloud and the 4TB My Book a few days ago, I was looking forward to seeing how fast was the USB 3.0 connected device over a gigabit Lan. This tested out to be about 25MB/s. 

Once I was satisfied that this combination worked, I enabled SSH to get into the device. As I had done this with the WD Live, I wanted to make sure that the devices would sleep and no photo indexing and other indexing would occur. So I use the chmod 644 method to ensure that wdmcserver and wdphotodbmerger won’t start. rebooted and watched both devices fall asleep within 10-15 minutes.

Satisfied that I could get device sleepage, I proceeded to copy 3.5TB files over the next few days. I filled my WD My Book using the USB 3.0 method rather then through the network with the same data. My intentions was to use the My Book as a mirror of the Cloud. Thus after all the data had been copied, I connected the My Book to the Cloud without any problems (I did not reboot nor power down over the few days).

After copying all the files, I decided to use the old method of stopping the services rather then using the chmod. So I chmod 755 back the 3 files and rebooted. I then use the above script to stop the services by SSH’ing the device right after rebooting. No problems in connecting… 

The problem started when I attempted to move my two devices over to my bookshelf connecting via 50 feet cat 6. 

  1. Connected all the devices including the USB 3.0 thinking it should just boot up… leaving all the services running. Remember my script to stop the services is manual; requiring me to SSH into the device to run it.

  2. the connection was very very sluggish. I thought my cat 6 cable was bad…

  3. powered off the devices without connecting via the web to shut down <====== This is where I think caused all the problems

  4. powered on without USB connected. Same problem. Unable to connect. I could SSH into it… but soon after the connection disconnected. Really thought it was a bad cable.

  5. brought the devices back to my desktop and connected via the short supplied cable. Had the same problem, making me realize that it wasn’t the cable.

  6. ps -ALL to see all these services and stop the two above… I was able to map out the drives on both windows and Mac

  7. Moved the drives back to the 50ft cat 6 cable… and did the above procedure. The two devices are happily working on my bookshelves at the moment.

Hope this helps in figuring out the next patch. There is something in your boot up that is taking up all the resources and finally disconecting the devices. It is made worse when you connect a USB 3.0 device and a flurry of activity occurs when you do connect a USB which is why we see reports of people having problems when connecting a USB 3.0 device.

I do not see the need of indexing. If there is a reason such as twonky or perhaps itunes, make it a manual process and allow people to select the directories for indexing. Make it manual, not automatic, or add a switch that when automatic to do it once a week, not every second.

I have reduced my 5 star rating of your device down to 3 stars. I do think your products are wonderful but very complex to use.


  1. I did try renaming unsuccessfully the Public folder to something else and when I tried to turn off public access, the window said updating… and I refreshed the web connection…

  2. the button for public access to the public folder is now grey out. Although I can assign access to the public folder, Guest is no longer allowed. 


Note. Since I could not rename the Public Folder (which I’m assuming you have hardccoded this directory somewhere), I created a new share directory that I could limit access to. However since I have copied 3.5TB data and you don’t have a way to move the directories, I SSH into the drive and used the mv command to move all the files from the Public directory to my new Share. 

There is nothing under the Public Directory now. Perhaps that may be a problem with your indexing program? and the button to make it public is still greyed out despite my attempts to change the permissions for the Public Folder.

You couldve just turned off media sharing if you didnt want the share to be indexed…also, have you tried to see if the device sleeps without turning off any services when you bought it? 

Yes turning off media sharing will allow your device to sleep.

As long as you have a “Reasonable” amount of photos and other media, yes the device will sleep. However the indexing of a million photos and other media is not needed as the device attempts to convert all my large photos into instant small photos for viewing in the app and this takes days if not weeks. I just need to store my photos as not all my photos are for viewing.

On my WD Live, everytime I add, move, change, the index process starts up… and I’ve noticed for the last two years, my WD Live never sleeps; until I turned off mediacrawler.

I do need remote cloud access which is the reason that I bought this device along with the NAS capabilities. The Cloud App works without needing to index all the media.

I would like the ability to select which photo directory that I can index and convert.

Each share that you create in the dashboard has an option to turn off media serving

I think if you turn on remote access then you do need media sharing turned on…

thus I do need media sharing but not the indexing…

Anyways, I do think it is the indexing that is causing all the slowdowns and even possible problem with connecting with the USB. Yes I have read many many times to allow the indexing to complete, however when you have as many photos, music as I have, I don’t need indexing. 

@ Ralphael,

I do agree with you that indexing is making this thing choke. All you need to do is as the other chap says if you don’t need indexing is turn of Media share on every share/folder as well Media Scan. Done. 

You have been copying via a Normal PC on a the USB port of the PC, this is what I found out and have written in another post. This the WDMC does not like. If you back up with Safepoint on the USB 3.0 port of the WDMC, the WDMC is happy. Do not take it off. The reason your WDMC became unresponsive is because you copied from the PC to the USB drive. I had exactly the same thing and issue. I decided to to delete the partition as well format it again keep it empty then hook it up to the WDMC and let it do Safepoint. This has been great so far, although it can take a while if you have a big portion of DATA as in your case. I have set mine to update overnight from a certain time and it has been great. Which is odd, because I had loads of problems before. Some how the “demons” have been coughed out from the device, because I have been copying large amounts of files, big and small amounts 10 Gb up till 100 GB and over this week and let Safepoint copy them to the USB 3.0 drive. No problems at all so far.


Yes it is totally true that if I did not copy via the usb and directly attaching the WD My Book to the WD Cloud and backing up with safepoint it works like a charm. It was one of my first test when everything was in pristine shape. However, I found that the safepoints was only backing up data at 10MB/s. This would be fine if I had intended to let safepoint do all the mirroring, but I do want to be able to pull off the USB drive to use as a normal PC drive once in awhile.

Now I don’t know if it is as simple as turning off Media Share to fix both problems.

  1. disconnecting from network 

  2. going awol (offline) when a usb drive is connected.

I do have a working solution and it is mentioned above. It fixes both problem as well as letting me access it remotely by the iphone app.

I can take off and put on the usb drive anytime. Copy data via USB or via the network without problems.

I do have two working drives with fixes to the problems.

@ Ralphael,

“but I do want to be able to pull off the USB drive to use as a normal PC drive once in awhile.”

Yes, you can, but don’t write to it, at least that was my experience. Copy to your PC yes and anywhere else, and copy back to your WDMC is fine.

I have the feeling that Safepoint writes in specific format over the WDMC to the USB drive and if your write with a PC to it as well, it mashes this up. This is the same with a ROUTER USB with certain type of harddisk, it is compatible, but not for reading and writing. Don’t forget you write with Linux to the USB drive and Windows writes different to a USB drive and my experience has learned, they are still not 100% compatible like that. Perhaps if you format the  drive to EXT2, EXT3 or EXT4 it might do it right and use it with a converting program on a Windows box. 

Converting EXT to read and write, look here:

and here

I know that works, but have not tried on the WDMC as such, but should be working. But still I prefer not to write on the USB external drive between two Operating Systems. Perhaps this should be argued between Linus Torvalds and Billy Gates.

Organisations always have fought for the majority to their side, but many organisations are at loggerheads for donkey years. Just look at Google and Apple. And who is suffering in it ? The customer.

Safepoints and reading and writing normally via USB is compatible.

I’ve tested this out.

Safepoint simply copies all your files under a single backup directory and your file formats can  be read and written to as normal. 

I have also connected a Vantec Raid Drive that has two sets of Raid Mirror drives to the Cloud USB port and I could mount, read and write in NTFS format safely.

However with this said… I do not know your setup and perhaps it could error out on your system and I do not want to be blamed. I am able to read/write, remove my USB drive, add another different type of drive, without problems (provided that I do the above method).

I was thinking of converting my NTFS to linux format as I do have a Mac and could mount the USB drive as ext; this is mainly for setting permissions. However my USB 3.0 is on my PC so until I upgrade my Mac with USB 3.0, it stays NTFS.

So I’ve had these drives for almost a week now and with the solution on my first post, I’ve been very very happy with the pair of drives.

I did some more testing by connecting my huge Vantec 8TB Raid drive via USB 3.0 to see how the write speeds were and they came out very poorly around 18MB/s- 25MB/s of which I don’t know why. However WD My Cloud does support gpt and had no problem writing to my 8TB NTFS formated drive. The same Vantec drives on my PC has a write speed of about 110-130MB/s via the USB 3.0 ports.

I did encountered a problem with un-mounting my Vantec drives as I waited for the WEB UI to show the USB connection so I could eject the drives. After waiting for 5 minutes, the USB connector never highlighted. So again, I went ahead and ssh into the device and killed off the two process (of which I’m not sure if they are related to this problem). However once I killed off wdnotifier and wddispatcher, the USB connector came up. Had to stop and start the /etc/init.d/wdnotifierd and /etc/init.d/wddispatcherd in order for the eject to process, otherwise it seems to wait forever.

Just to make sure, I re-mounted my WD 4TB MyBook and the MyBook showed up immediately.  Did the same write test by copying 3GB of data to the USB drive and just as I remember it,  the write speed to a WD 4tb My Book through the USB port is about 40MB/s.

I am very impressed with the WD Cloud NAS as I could copy data from the NAS down to the Vantec Raid Drive (connected to my PC) at about 70-80MB/s.

After price matching with NCIX, the WD 4TB Cloud drive came out to  $190. 

Both drives are a keeper.

edit: incidentally , I also tested the speed of copying directly from the WD Cloud to the USB 3.0 WD MyBook and the speed was 40MB/s which tells me that since we only get about 40-45MB/s write speed to the NAS, the USB 3.0 port has been limited to 40MB/s also, otherwise USB 3.0 speeds for device to device should be over 100MB/s.

I use the linux command 

cp -r /shares/… /shares/My_Book

Hi everyone,

I share my experience:

- I disabled ipv6;

- and I stopped two services through crontab (S85wdmcserverd and S86wdphotodbmergerd)


and my My Cloud 2To seems to be stable since yesterday.



Can you give me the steps to do this please? I’m pretty technical but SSH is and mac are new to me.