My poor experience updating to the 4.0 firmware

My NAS was working great on the v3 firmware. I had no issue whatsoever, but I updated the firmware anyway, not sure why…

[Edit] To be clear about something: I didn’t install any third party software. The only tweak I did through SSH was removing the size constraint on the Twonky DLNA server that make the movie thumbnails all weird… This is just an edit of a config file.

The update process was easy.

Upon reboot the UI became extremely slow. About 45 second to complete displaying the home page. The list of users and shares would simply not come up after a minute or so. I didn’t wait longer, so I am not sure they would come up at all. Any toggle setting on any page would show up after 10 to 20s, one after the other. In short, the UI was unusable.

The mapped network shares were connecting very slowly on Windows 8.1, and would always show disonnected for several minutes despite rebooting the computer.

I didn’t test the copy write speed.

On the first reboot, the device got stuck with a steady white light for one hour. After one hour, I unplug the device and it rebooted right. Same UI slowness. Same share connection issues

I eventually performed a quick factory restore. I thought I was OK because I had a recent Safepoint complte.

The quick restore went fast, and the UI came up much faster, but still way more slow that on the previous firmware.

I tried to restore the safepoint, but it fails within 30s, telling me that the share operation was invalid. Not sure what operation it was. FYI, I have renamed the default mac backup share, and deleted the smartware share. I tried to delete all share before using the safepoint restore, but it fails also. So, BEWARE, your safepoint data can be OK, but the restore function might fail.

Luckily, the safepoint technology leaves the files flat. So I restored all the folders and every share manually using a file copy from a computer.

Yesterday during the copy, for the first time ever, the NAS dropped completely from the network. It had its happy blue light and the UI was available, but no share was available. I interrupted the copies (grrr…) and rebooted it.

After another night of copy, the device is up and running, the 2TB copies completed after I decided to lose all my mac backup. The time to complete the copy was another 11 hours. That would be longer than recreating a new fresh backup from Time Machine.

I am now recreating the safepoint from scratch.

I am sorry to report that the safepoint was not reliable for me, which becomes a significant issue as you cannot restore the NAS and then restore the content from the UI.

I had a similar experience…  Opened a case with this detail:

Did the last firmware update (v04.00.00-607) hoping it would resolve some of the speed issues, connection failures and streaming difficulties. The firmware update made things much worse and much slower and removed remote connection as a possibility all together.

Based on other FAQ and knowledge base posts I performed a “System Only” restore assuming that the “user data” would be left untouched and the file and share data preserved. Shares were unaffected, but all users were removed and only Admin is present.

To speed things up and redo configuration I have changed the following:

Media Streaming: Off

iTunes Server: Off

SSH and FTP: were left Off

Static IP setting: configured as appropriate (Gateway, DNS, netmask, and IP address set)

Mac Backups: Off

Drive Sleep: Off

Cloud Access: Off

NTP: On (added

Timezone: set to -5

Device Name: changed from WDMyCloud to another alpha only name

System reports that it has internet access

Almost every config change or page load takes at least 30 seconds to process. All users were removed by the System Only restore, which would have removed all of the cloud access connected devices as well. I have already had one of these units replaced, and the data migration is not something I am willing to go through again.

Even the initial screen takes about 45 seconds to load.  Adding the users back takes about 30 seconds per user just to create the accounts.

I am hopeful that over time the system indexes itself or does whatever it needs to start running faster again.

I would love to see this thing finally doing what I purchased it for (streaming, remote access on my phone, etc…) or at least as a reliable network storage device.

Just waited two minutes to add a user…

Now onto the shares page, taking over a minute to load that…

Then the time consuming part of adding security levels to each share.  This is going to take me several hours.

Yep. Despite the quick factory restore (which erases all content and reinitializes the firmware and disk file system), the UI is still much much slower than previous firmware version.

The home page takes about 35s to load all the information. The last one to appear is the number of shares!

Any other page takes between 10s and 15s to display status of toggle switches, although the firmware page took 20s just to display whether the auto-update was on or off…

With the new firmware, it appears there is some improvement in the USB 2.0 support speed and/or the rsync performance. The new safepoint is on track to exceed 24h to copy about 980GB of data (I decided not to reload about 1TB worth of Mac machine backup). At this point, the safepoint is at 10% for 98GB copied after 2.5hours, or about 11.15MB/s. My previous experience with the older firmware was about 7MB/s.

Copy speed is lot slower than the 3.X firmware, my average before is about 20-30MB, now it’s about 2-10MB.

I updated my firmware as well and you guys are def right! My DLNA access is gone, had to reboot my device and wait an hour for the white light to change blue, and the copy speeds are also slower. I copy all my legally downloaded movies :slight_smile: on a separate share through ssh and ive noticed that throughout the copy process the speed drops, stalls, then resumes periodically. Average speed dropped as well. What is up with this firmware??

Also i had to delete the RSA key from the secure_hosts file so that i can resume connecting through terminal. This is the first time this happened, all the other firmware updates did not require this.

Ok well… Doing a complete quick system restore didn’t improve the slugginess of the UI. The home page still takes up to a full mn to load completely (unbelievable).

Updating access rights to shares (for example make a USB share non-public took 15mn !!!

Now, blue light but device is no longer responding.  Drive mappings are no longer connected.  Ping to IP result in responses, but attempting to pull up web interface fails.

I am very upset.

Cannot browse by name or by IP.  Still no response on my case.

Did you try to reboot the device? After updating, for the first time ever since I have this NAS, it disconnected from the network, but a reboot fixed it and it has not (yet) disconnected.

I know I did attempt to reboot…  several times…  with hours between the attempts.

Just initiated the 45 second reset, and going to see how it works there.  WD just called me as well and they will be providing me with details about how to roll it back.

Try to uninstall the “Quick View” Tool an reboot the drive and computer. The tool sends a lot of requests to the webinterface (apache2), so the drive is not able to respond to user interaction. This solves the problem for me.

Tried the reset where you hold the reset in for 30 seconds.  Not much better and had to reconfigure all of the settings.  Downloaded the firmware to my hard drive and manually reapplied the firmware.  Things are going much faster, but all users are gone again and when I add users, they are not being allowed access to the system.  When I try to connect and map drives it asks for the username and password, but will not take them.

That asside, it is working much faster…  well the gui is working faster.  Can’t test anything else until I get access to the drive again.

My NAS is almost back to pre 4.0 status. I noticed higher copy/read performance to the NAS and from the NAS to the USB disk. That’s good.

The safepoints are now completing without problems. I believe my first automated safepoint failed because a Mac was still backing up to the NAS during that Safepoint.

I didn’t test remote access yet.

The UI home page is not faster, but slower than with the 3.x firmware. It nows loads within 15s, sometimes longer, but it is bearable.

Recreated my users, and set the rights to each share (which took a while).

Cannot connect through Windows to the device once I turned off “Public” because it doesn’t recognize the usernames.  This is annoying, but I believe it still had the user data “saved” and isn’t recognizing them now as valid.  More experimenting.

Yes, I did confirm that the users had the appropriate security level for the shares.

Created new user, and set rights for it…  also, could not connect.

Rebooting unit to see if the rights work after a restart.

Had to create entirely new users with different user names to make the network connections.

Also note, If you set multiple rights all at the same time and have several shares “updating” with the “please wait”…  you really should just do one at a time.  No certainty that multiple rights changes will all actually post to the NAS if doing several at once from the Users screen.

Ok enough is enough. With this firmware, the shares are dropping from the network as never before with the v3. I am downgrading the firmware. Very disappointing.

I have good news, I think mine is working…  Here is a rundown of what I learned:

Originally did the following:
From WebGUI Settings tab, clicked “Check for Updates” and let it process the firmware update on it’s own.

After update WebGUI was slower and much less responsive. Drive was not available on the network (either by IP, or name, or wdmycloud). Was only ever able to get Cloud Access working sporadically on my phone, but now the device would not connect at all and showed as offline on the website (

Power cycled the unit, with slightly better results, but still not usable.
Changed all shares to Media Serving OFF
Disabled (turned off) all settings that would slow down the basic config (Media Streaming, iTunes Server, SSH, FTP Access, Cloud Access, Mac Backups)
Turned Drive Sleep Off… not even sure why this is an option, or why it is defaulted to On.
Set to Static IP
Still, GUI was really slow and drive speeds were horrible

Decided to perform a System Only restore noting that this should not remove the users…
Users were wiped out, all shares were reset to Public Access ON, and system was still really slow.
Performed the same disabling and config as above to speed up remaining config (Device Name, Time Zone, Static IP…)
Still, GUI was really slow and drive speeds were horrible, and authentication was not happening

Tried the reset initiated by holding in the button for at least 10 seconds (varied reports as to the needed time from WD agents, I actually held it in for 40 seconds as that was the longest suggestion by any of the representatives I spoke with)
Performed the same disabling and config as above to speed up remaining config (Device Name, Time Zone, Static IP…)
GUI still slow, but better than other times (initial page only took about two minutes to give me a login option)
Attempted to recreate the users and reset the rights without success.

[Note, I learned this later, but it is important to state now… if users are removed by some process of the system, new users “MUST” be created and “MUST” be named something different than any old users. Some elements remain in the OS that will link users with a new name to the old credentials, with very limited success that will result in network authentication failing.]

[Note, when setting user share rights, even if it takes 30 seconds per click, only do one share/entry at a time. If you click several rights changes at the same time, you will not necessarily get those rights even if the system stops responding with “please wait” and looks like it has processed those changes. One at a time, or else!]

Spoke to Level II, who heard all of my trouble shooting and said that I had covered all of the bases and that likely the only option would be to RMA the drive… again.

Because I didn’t want to go through the trouble of copying all of the data and attempting to deal with the RMA process again, I informed him that I still wanted to try some things… I suggested that I would like to download the firmware and try the Manual Update. He agreed that that would be a valid thing to try…

Downloaded the 4.00.00-607 firmware from and put it on my hard drive.
Used the Manual Update “Update from File” option and let the system have at the firmware again.
After the install and reboot… GUI was soooo much faster.
Performed the same disabling and config as above to speed up remaining config (Device Name, Time Zone, Static IP…)

After trying to recreate them and reconfigure the rights (which was still a long’ish process), users could not connect through the network (“invalid user” I believe was the error on the Windows devices). Realized that as I added back users with the same names as they were previous, some of the users were getting “some” rights to some shares automatically. This lead me to do more testing and I discovered that a brand new user with brand new share rights (selected and processed one at a time), could connect to the device from my Windows computers. Created all new users, set share rights for each user one at a time, and deleted the failed “replacement” users I had created. After this, connected to a share and saved credentials with no issue. User access restored. Note, I did not put email addresses in at this time so as to not over complicate things.

After users were all reestablished went though all shares and turned off Public Access on all of the ones I wanted more control over and made sure user rights were accurate.

Media Server:
After system seemed stable turned Media Streaming back on. Did not turn on iTunes Server (mostly because I didn’t intend to use it, but also because I had read reports about it being a stumbling block to the performance since it hangs on some sort of file… Doesn’t matter, left it off mostly to make sure I had control over my testing).
Went to the few shares that I wanted to work with Media Streaming and set Media Serving to ON for those few directories.
Connected to the Twonky server ( http://wdmycloud:9000/ ). Configured the Navigation Tree to By Folder because I like that more. Under Sharing, set /Public to “Photos & Videos” (due to another report I had read that suggested the Media serving gets angry at some music files and hangs the system, and also to eliminate that as an issue. set my share that is just for videos to “Videos” so I wouldn’t get a whole list of other files that I don’t want (like images left over as part of WMP scanning them and so forth or music that was placed here by mistake).
Hit the share from my smartTV and all went very smooth. Interface didn’t stall or take several minutes to load the data and playback was clean and responsive.

Cloud Access:
Some of this was trial and error, here is what worked…
Deleted my device from
Deleted my device from the app on my phone and tablet.
Turned Cloud Access, Remote Access ON.
Left the Cloud Access Connection Option for Connectivity on Auto.
Added an email address to one user.
On the Cloud Access tab, select that user
Clicked the “Get Code” button and used that code to add the NAS back on my phone and tablet.
Working very well on my phone and tablet at this time. Cloud Access shows “Connected, Port forwarding connection established”

[Note, router settings… I had previously set port forwarding for the NAS IP address for port 8080 and 8443 but it had little impact. I presently still have those ports forwarded, even though I have the NAS set to Auto so I doubt it is using them. I also took the easy way out and just put the **bleep** thing in the DMZ. This is the one area I still want to go back and research a bit, but I like that it’s working, so am leaving it for right now.]

I share all of this with you so you know that I am working, I believe, and so that perhaps my research and finding will help you or others.

1 Like