My PC's and phone can connect wirelessly, but outside phone does not find mycloud

I can get on my cloud easily on my network, but now, I can’t connect with my android phone and I don’t know how to reset the application. I recently changed networks as the router konked out, Inside the house, I can connect wirelessly with my cloud through the phone, but outside, I can’t. I am not sure if I have to uninstall the my cloud app and then download and reinstall, I can’t find the place to check the settings. Any help will be appreciated

First step is to ensure you can access the My Cloud via the MyCloud.com site. If you cannot connect through the MyCloud.com site then access the My Cloud Dashboard to ensure the Cloud Access Remote Access setting is enabled. Then navigate to the Cloud Access section and ensure the users you want to have access are configured to have access. You may also have to log into your broadband router’s administration page and ensure the broadband router is configured properly and is not blocking access to the WD My Cloud.

If you can connect through the MyCloud.com site to your local My Cloud then you may have to remove the My Cloud device entry in the Android app and re-add the device.

I can connect using the mycloud.com site in the browser, I went into my att router and chose instead of my computer, I chose > Choose WdMyCloud instead, don’t know if that is a good choice though. I’m thinking about switching back and then removing my phone and re-adding it? I see the get code, but I’m not sure if it sends me the code to my phone in an e-mail or text and maybe that is why I need to remove it and add it again. I tried earlier, but there was no place to put the code in my phone.

With the Android WD My Cloud app select Settings -> Manage Devices -> Add Manually -> Add Device. Then enter the pin code generated via the “Get Code” option on the Dashboard’s Cloud Access page and hit the Activate button. Its best to remove the non working WD My Cloud from the Android app first before adding it back just to avoid confusion.

For the WD Photos app select Settings -> Add Device -> Connect Manually -> WD My Cloud icon. Then enter the code and hit the Activate button.

Edit to add: If one is on their local network both mobile apps should pickup the WD My Cloud automatically and allow you to add it by simply selecting it rather than having to enter the code. For the WD My Cloud app it should show up under Available Devices on the Manage Devices screen. And for the WD Photo app it should be listed under From Your Local Network on the Add Device screen.

I followed what you suggested and now, I am back and was outside and still able to connect to mycloud, so thanks for your time and effort in helping me resolve this issue, I really appreciate the help! :slight_smile: