My pc doesn't allow me to use WD External Drives

I have an WD Elements 2TB external hdd and when i try anything to use that i transfer/install on it it says that i don’t have perms. I have given it every perm, i formatted it multiple times, i even reinstalled windows and it still doesn’t work. I put a WD extern drive from one of my friends and it says too that i don’t have perms, but when i given my WD to my friend to test it on his pc it worked. The hdd was used before on my Xbox Series S, though that shouldn’t be a problem because i formatted the hdd multiple times.

Hi @zynx,

Please refer to the article Resolve External Drive Not Detected by Windows or macOS Guided Assist:

Please contact the WD Technical Support team for best assistance and troubleshooting:Submit a Case | WD Support

Hello @Keerti_01
Im going to submit a case to WD Support, but External Drive Not Detected didn’t work for me. As i have told you up, the problem is that i don’t have perms to do anything on the drive, like opening an file transfered on it, even though i gave all of the users on my pc (My user and an Admin user) perms to the hdd.I tried the resolve problem but they did nothing. Thank you tough !

  1. Try a different OS or an earlier version of Windows.
    Verify whether a different OS can access an external drive. Try attaching an external hard drive to a computer running Linux or Mac OS if you are using Windows, for instance. A prior version of Windows can also be used (7 or 8). It’s possible that the OS and your external hard disc are incompatible.
  2. Get the required authorizations
    As was already noted, the absence of the required rights to utilize the disc may be one of the causes of an external hard drive’s access being prohibited in Windows 10 or 11. So getting those permissions is the logical next step.
    Go to My Computer / This Computer. Select and right-click on the inaccessible disk. From the list provided, left-click “Properties” > “Security” > “Change.”

Then a new window “Permissions for a new volume (E :)” will appear, where you should click on the “Add” tab. Now you need to add a new user (“Authenticated User”). Click OK.

Go to the Permissions section. Check the box on the “full control” tab. Click OK.

3. Use Command Prompt

  1. Connect your external hard drive to your PC.
  2. Right-click Start and open Command Prompt (Admin).
  3. In the command line, type the following command (assuming that your external drive has letter E: assigned):
    takeown /f e:\ /r
  4. Reboot your PC and look for changes.
    Hope this will help you.

Ok so at 1. I tried the Drive on two different pcs and it works. My pc seems to not accept only WD External drives, because i have an WD internal drives and it works, i tried with another external drive and i got the same error.
2. After i press ok i have the error Failed To Enumerate Objects in the container.Acces is denied.
3. after i put the command modifyng E to K because that’s my drive initial i get this error
ERROR: The current logged on user does not have ownership privileges on
the file (or folder) "k:"

The error message you are seeing indicates that the current logged-in user account does not have sufficient permissions to access or use the WD External Drive that is assigned the drive letter “K:”.

To resolve this issue, you can try the following steps:

  1. Ensure that you are logged in with an account that has administrator privileges on your computer.
  2. Connect your WD External Drive to your computer and wait for it to be detected.
  3. Right-click on the “Start” button in the bottom-left corner of your screen and select “Disk Management”.
  4. In the Disk Management window, locate your WD External Drive, right-click on it and select “Change Drive Letter and Paths”.
  5. Click on the “Change” button and assign a different drive letter to your WD External Drive, such as “L:”, “M:”, or “N:”. Click “OK” to save the changes.
  6. Close the Disk Management window and try accessing your WD External Drive again.

If the above steps don’t work, you may need to take ownership of the drive. Here are the steps to do so:

  1. Right-click on your WD External Drive and select “Properties”.
  2. Click on the “Security” tab, then click on the “Advanced” button.
  3. Click on the “Owner” tab, then click on the “Edit” button.
  4. Select your user account, check the box that says “Replace owner on subcontainers and objects”, then click “OK”.
  5. Close all the windows and try accessing your WD External Drive again.

Hopefully, one of these solutions will resolve the issue you are experiencing with your WD External Drive.

1 Like

One potential solution could be to try connecting the drive to a different computer to see if the same permission issues occur. If the drive works without any problems on another computer, it’s possible that there could be an issue with your PC’s USB port or drivers.

Another possible solution could be to try accessing the drive through a different file explorer or utility program to see if that resolves the permission issues. You could also try duramax running a disk diagnostic tool to check for any errors on the drive that could be causing the issue.