My passport won't shut down properly. Help please

Hi, i have a problem on Windows when removing my hard drive.

When i click on “safely eject this device” (Windows), the usual text appear (“You can now remove safely the device”) However the disk does not shut down, the led is still on and i can hear it … It is only when i remove the USB cable that the disk stop.

Is there any way to fix it so it does a proper shutdown ? (Without needing to remove the USB cable)

Side note :
I tested it on Debian (GNU/Linux) and it work well, the HDD stop (I don’t need to remove the USB cable)

Product concerned :
3 WD My passport (295 GO, 1 TO, 2 TO)

ex672…interesting…I normally leave my Passport attached while logged on since I store other folders that I use besides the Backup Folders. However, your thread was curious.

  • I tried the lwr rt task bar Eject, and got a message about a program using the drive.
  • I then exited my Explorer, thinking that it had a connection…nope, I’ve had this open when I’ve ejected (both task bar and rt mouse eject…Passport does not have a rt mouse eject).
  • went to look at the Task Manager for processes or apps that are open…Nothing…
  • mmmm a little curious. I could wait till I shut PC down, but that defeats the purpose of Ejecting the Passport after finishing using it. Yes, the LED blink lite is still on, an Passport never ejected.



I did some snooping…

  • I found WD items running under Task Manager…so these may have a lock on the Passport devices in the background. You could End Tasks that should start up when you reboot the PC.
  • also read something about Removal of USB thru Device Manager. See Craig3 and Randy, in Feb and Oct… Cannot Eject My Passport
  • they point to a Device Manager, rt click the USB drive and Properties…next to Policies…
  • I have not tried this Better Performance, but implies that you must use the Safe Eject…need to do more studying.

One of these items may work…I have 2 Passports, so ending the task kills both from accessing the WD software, but should make them accessible for Ejecting or Viewing. Who knows!

Forgot to post the Task Manager Processes of the WD Apps. Memory is constantly changing so there is interaction with this and the Passport…must be why cannot Eject. Not sure if the Better performance option on Device Manager…I’m not suggesting that this would work…

  • Note: if some App is actually writing to the disk and you Force Eject the USB, Explorer could Fail.

Hi, thanks for your reply.
After hours of research (7-8 hours) i have finally “found” a solution.

On Windows only (I don’t know why, on GNU/Linux you are fine without them) you need only two applications :
WD Quick View
WD SmartWare
Note : I don’t find WD Security useful. (It will make your drive non working in Linux plus the “security” is bullshit). A better alternative consist of using Veracrypt or TrueCrypt 7.1a

By using WD quick view i was able to safely eject it AND to make the external HD shutdown automatically WITHOUT having to power off or reboot my computer, nor having to remove the USB cable.

The newer versions of WD quick view, WD SmartWare (Don’t exist anymore ??) doesn’t work, they wil only disconnect the Hard Drive without shuting it down.
You need to find older versions. I used this website >

You need older versions of WD quick view and WD Smart Ware on Windows. I didn’t found others solutions sadly …

Here is a list of other alternatives i have explored on Windows (All of them don’t work)

1° Trying to use the basic Windows “safely remove your device”

2° Trying to remove it by USB Disk Ejector
quickandeasysoftware . net

3° Trying to use Power Management USB

  1. Press Windows key + R on your keyboard, type devmgmt.msc, and then hit Enter.
  2. Expand Universal Serial Bus controllers.
  3. Right-click the USB Hub, and then choose Properties.
  4. Click Power Management tab, and then enable Allow the computer to turn off this device to save power option.
    Source :

4° Trying to use the program Drive tools
Command Line :
“Eexecutablepath” “:letter” -L
RemoveDrive.exe f: -L

ex672c…Thanks for the thread into this issue. After I realized that I too had the same, it allowed me to research the problem, in both this forum(back to 2015) and Microsoft. I believe that the fix is in the Win10 Device Manager option

  • assuming you want to always use the Safely Eject the Passport USB found in the inverted V tool tray by clock.

  • type Device Manager in the Win Search, open to Disk Drives, rt mouse to Properties then Policies. Change the entry from Quick to Better.

  • someone pointed to a Microsoft link that had a greater explanation. I did find some differences with info…however, it Worked!

  • I had 2 Passports so I was able to play with this option. After modifying, the PC must be restarted in-order to activate. Specific E or H drive was not identified.

  • I even tried moving the chosen device to other USB ports, (Microsoft mentioned that it was port related change). I could not find this to be true, every port said,. Better Performance.

  • I was then able to Safely Eject the specific device, wait for the Pop-up msg about safe eject…

  • Note, if you do not physically remove, there is still power to the unit shown by the blinking LED lite.

  • Reinserting the Device, activates the drive and a Explorer window appears.

  • ex672…your link to the Power Management, I believe will power the unit (as I said, if you leave it connected after Eject, power is still going to it, so just remove the USB chord

  • finally, under the Universal Serial Bus, I got this msg after Ejecting, but not Removing the Device. After doing so, and re-insert, I get a “Device working Properly”


Give this a Try!! I believe Manual Safe Eject eliminates issues that some App is writing to the USB when you pull the chord…and loose cache or messes up the drive itself. I even eject Flash drives by this method or the Eject that appears on the Explorer rt mouse.