My Passport wireless pro 2TB no mounting/recovery data

Hello everybody!!

Well as many of you I have problems with my device. A couple of days ago I plugged in my Macbook pro as I do every day and I notice the it is not showing up in my desktop. Several hours later stills the same, not showing up. I tried to enter from Mycloud app in my mobile, nothing. After many attempts I decide to restart the wireless pushing 10 seconds the buttons but nothing happened, just fast blinking blue lights. So I decide to delete the device on app. I tried again to pushing the buttons 10 s but same thing of blue lights. I plugg it again to the laptop and it works, I check that nothing was deleted and I unplugged it (oh what I’ve done). Of course, I didn’t know that it was a good chance to move my data to my other device (f*ck!!). So that was the last moment what it worked like normal, after that is showed in disk utility but in grey color. I tried to mount that partition or whatever it is and it’s not working.

So now my questions are, if I plug it to any laptop with windows It will work? I dont have windows laptop, just Macbook but I read that could it work. Could a data recovery profesional store recover all my data? Do you thing I lost all data or very amount of it? How much will cost recovery almost 2TB?

I need a light of hope because I have very important data (Now I’ve learned that I’ve to make backups).

So If you reached here thank you so much for your time I appreciate it.

I would like to attach screenshots but I don’t know how to do it.

Anybody plugged it on laptop with windows 7 and it worked?

could be a problem with OS X if the disk is visible to a windows machine

1 Like

Hi Vegan!! Thank you :blush:, I was thinking that, did this happened to you?

(The problem is I don’t have access to any windows machine :pensive:)

I have both Apple and PC equipment so recovery of data can be attempted

must be somebody you know with a PC

There are number of reasons why your hard drive, flash drive, USB drive, or SSD might not be showing up. It may have been formatted incorrectly, it may be corrupted, it may have a faulty (or inadequate) cable, or there could be something else. To fix the problem you can try the below methods:

  1. Edit your Preferences under Finder Preference
  2. Check the cable
  3. Try on another Mac and then try on PC
  4. Use Disk Utility for First Aid
  5. Change the Drive format
  6. Try data recovery tool

If above methods won’t help, then try using reliable data recovery tool such as Stellar Data Recovery to recover data from affected drive. Further, you can also check the below for steps to be followed in each method mentioned above:

https://www.macworld.co.uk/how-to/drive-not-showing-mac-3613422/

Hope it helps!

Hello Jose2020!!

Thanks in advance for your help. The cable works because I tried with others external hard drive, I tried in other Macbook, I didn’t format it, I didn’t eject without permission, you know click on icon, eject, … I think the first problem is Macbook with Big Sur doesn’t mount the disk.

Before try other format I have to format the disk right? I can not do that because I have data.

I tried many software of recovery data and they found 0 data, I want to think it’s because those software could not mounted the disk.

Ah!! And I have many extra cables too.

If it helps to anybody …Today I went to a recovery data shop store and they give me a budget about how much will cost to recover my data from 2TB. I have to say my disk it’s 2TB and I had 28 gb free. The price is around $1200, it could be more higher if they have to do extra job or replace a piece or whatever.

In a couple of days they will contact me to let me know about my device and what problem they found … I will let you know for if it helps someone.

Update: my passport has a electronic & mechanical failure. So they have to replace some pieces temporary for make it work and get the data.