My Passport Ultra and PS3

Dear All,

I bought a WD My Passport Ultra 1TB drive to use for media files attached to my PS3. However the drive doesn’t seem to connect.

I have reformated the drive to FAT32 and laid out the file structure in the required PS3, VIDEO, MUSIC, PICTURE, way, I have even tried using a powered USB hub in case the drive wasn’t drawing sufficient power to run.

When I connect the drive the light on it flashes for a short while then remains on solidly, however it still doesn’t appear on the PS3.

I’ve used a 320GB My Passport drive for the same job for a little while now with no problems, so I can’t figure out what I am doing wrong.

Any advice would be much appreciated. 

ghjkl,

Please bear in mind that the WD Passport Ultra was designed with computers in mind, and optimized with encryption and data protection systems. As such it has not been tested with the Sony PlayStation 3. I would recommend the WD Passport AV in this case as it has been tested for compatibility with the Sony PlayStation 3.

Hi,

That is pretty disappointing if that is the case. Seems ridiculous that it wouldn’t be compatible.

I am now stuck with a drive I have no use for. Absolutely waste of money as the shop won’t accept a refund on an opened item. Very cross with WD about this. 

Hi ghjkl, not supported doesn’t mean that it wont work, but I recommend you to check the Sony support page for any information on how to configure USB external drives, so they can work with the PS3. Also avoid using USB extension cables or USB hubs to connect the Passport, since longer cables can cause power inconsistencies. 

Hi,

I have used other drives without any problems, for some reason this time the PS3 doesn’t seem to detect the drive.

So far as I can see it is seet-up correctly, indeed I have set it up the same way as the drive it is to replace which worked well. 

Unfortunately it would appear that not supported does mean doesn’t work in this case.

Also some drives that use a password have a virtual CD on the drive’s hardware  which cause problems with connection even if you don’t set the password.

Joe

I just tried my Passport Ultra Slim with my PS3 to test if I had a similar issue and yes, PS3 doesn’t seem to recognize the Ultra Slim drive either. On doing a quick Google search I found, as I suspected several USB 3 drives have issues with PS3 -> http://www.ps3news.com/forums/ps3-help-support/usb-3-0-hdd-incompatible-ps3-help-126126-post452212.html#post452212

It appears, the solution might be to get a USB hub.

I did try with a powered hub but no success, other drives did work through the hub but not the Ultra

I am hopefully going to get an Elements drive, in the next few days, to see if I can get that to work. 

The PS3 may also have a max disk size it can use. You might find more help posting in the TV area. An Elements is a simple plug and play drive wthout hardware encryption.

Joe

My Ultra Slim drive has no encryption on it…but Joe_S may have a point about the max capacity of USB drives that PS3 can recognize. My Slim drive is 2TB. But I am still for now leaning towards an explanation that may have to do with power - thereby requiring an USB hub. I’m not sure. Will have to play with it more when I have time. For me it’s not that much of a pressing issue.

I managed to get an Elements 1TB drive, which is also USB3.0 and after a quick format the PS3 picked it up without any problems.

Didn’t need to use a hub, it just worked. Still none the wiser as to why the Ultra didn’t connect, but at least I was able to get something working.

you haven’t answered the Q - is your drive locked using wd security? if so, unlock it first on a pc and then connect it to your ps3.

there’s not problem with the drive, its a standard harddrive. there’s no use blaming WD for something that’s out of their control.

Hi,

So far as I can tell there is no security on the drive. I had completly reformatted the drive, and even deleted the original partition just in case. 

sure, all that doesn’t matter since its at the least, just a harddrive. If it shows up correctly on a windows and/or linux pc, there’s nothing wrong with it or the formatting. There’s some restriction in the ps3 then. talk to sony.

The new drive works perfectly, as have previous drives. It seems to be as long as the drive is set to FAT32 a PS3 should detect it. 

I did previously look for a solution to the problem on gaming forums, and many other people seemed to be having trouble with WD drives. This may just be because they are perhaps the most commonly used and not especially because of an inherent problem with the drives but WD did seem to be the make a referenced in a majority of problems.

A previous poster was also unable to get an Ultra drive to connect. It seems odd to me that an Elements would work and the Ultra wouldn’t, when they are both USB3.0 and 1TB in size. I’m leaning more toward there being some reason that comes from the drive, more than the PS3.

I did see one post elsewhere in which the poster had made referenced to hidden security files on a drive which needed to be removed seperately from the formatting to get a WD drive to connect to a PS3. However they didn’t elaborate how to do so, or how to know if it was needed, just that they had done it and previously non-connecting drives had worked. It may that causing my problem. Though there didn’t appear to be anything else on the drive.

Happy with the new drive now anyway, it does what I want it to!

Again, if the drive works in other places, there’s no reason to suspect anything is wrong, is there? If it doesn’t work in other places, then you have something to complain about. 

I dont know exactly, I admit. maybe ps3 is using some proprietary port which somehow works with elements but not with ultra. But that has nothing to do with WD per se. Sony has a track record for proprietary stuff in all their hardware.

People don’t understand what the WD security software is and just keep blurting out stuff about deleting some hidden partition, files etc. Fact is, it doesn’t work that way. First of all , if you don’t have it locked, then the WD virtual CD partition will not even be visible. - simple, just a plain harddrive.

if you do have it locked, yes the virtual CD partition will show up and you’ll be able to unlock it only on a mac or PC with windows. if this is a problem, remove the password. its that simple. There is really nothing more to it.

and btw, the virtual CD partition is dynamically provided to the OS by the firmware. It doesn’t reside on the usable part of your drive and there’s nothing you can do, or need to do, to remove it.

Oh. I have one last point: Its just possible that because of the design changes in the ultra vs elements, the ultra needs more power from the USB port compared to elements. maybe the ps3 port is not supplying that power. Just because the led lights up doesn’t mean that there is sufficient power to run it correctly. If that’s the case, then yes it won’t mount at all on the ps3. There is no easy way to verify this, unless you want to use a multimeter and know how to check the voltage and current flow thru the USB port. 

Here is a blog which talks about the power problem with drives powered using a single cable:  ref

Well, I forgot PS3 only recognizes FAT32 formatted drives (after it was mentioned in the 2nd last post above a quick Net search revealed that fact). The Ultra Slim drive I connected to my PS3 that it didn’t recognize was formatted as NTFS. Now I get it. Very simple explanation.

ok, that is straight out of the manual, so next time, [Deleted]:slight_smile:

Hi,

I just created a new account here to share my recent success. I don’t have a Passport Ultra, but I do have a Passport Essential. At first I could not make PS3 detects the external drive. In fact I could not make it detects any of my USB mass storage devices. I had tested it with Passport Essential 500GB, My Book 1TB, Sony Microvault Click 8GB, and Sandisk Cruzer Micro 16GB. All were formatted as FAT32, of course, following the advice in numerous articles and forum posts. I was beginning to worry that my PS3’s USB controller had broken.

Well, it turns out that there is a missing information in those articles and forum posts. I finally realize that in order for the USB mass storage device to be detected by PS3, the device must be using the good old (legacy) “MS-DOS” partition table, also commonly known as “MBR” partition scheme. Newer operating systems such as Windows7, Mac OS X, and most modern Linux distros (I use Fedora to format) tends to create partitions using GUID partition table (GPT) instead, especially for those terabyte disks. PS3 does not read a USB device with GPT even though in the table all the partitions are FAT32.

With this insight, I then converted all my USB mass storage devices from GPT to MS-DOS partition table. I use a command line tool in Linux to do this conversion without have to reformat the existing partitions. Now, all my USB devices that I listed above are detected by PS3 directly, no USB hub required. Your mileage may vary. If you don’t know how to convert the partition table, just reformat the disk again using a partition tool that let you choose between GPT or MS-DOS partition table, and remember to choose the latter. I know “Disk Utility” on Mac has this option.

Oh, while I am at this. I also want to correct some missinformation out there. PS3 can detect primary FAT32 partition. It is not necessary to create it as logical partition as most of the articles/posts claim.

Hope this help.