My Passport Ultra 2TB, cannot access stored data

Greetings all. I come to you with my troubles.

  • My Passport Ultra
  • 2Tb
  • P/N: WDBMWV0020BBK-01
  • OS: Win7

I’ve discovered recently that I cannot access the data stored on my drive. When plugged in, I (sometimes) can see the drive on the My Computer screen (though it says “Local Disk (F:)” instead of what I’ve named it). If I double-click the drive’s icon, the green Loading bar in my browser’s address bar begins to fill (as though it was loading), but even when that bar fills, nothing happens. I’ve left it in this state overnight, and nothing loads/shows. I cannot access it in Computer Management, nor would it show up in the “WD Security” software. Some minor things I have tried, on my end:

  • tried different USB cables
  • tried different USB ports
  • tried different systems (on my PC and on my laptop)
  • tried to access in Computer Management
  • tried to access in WD Security software
  • tried accessing the drive when my PC was booted in safe mode (not sure what I thought this would help/change, but I tried it anyway)
  • tried to access in XBox 360 and in PS4 (nt even sure if these systems can accept external HDDs, anyway)

Sometimes when I plug he drive in and try to access it, then remove it later (after if again doesn’t load), I get the “This drive needs to be formatted” message, even though the drive has already been reved. Also, oddly enough: when I try to access the drive or do anything to the drive via my browser, everything Windows-related is slowed down. Way down, almost to unoperability. Example: if I plug the drive in, go to My Computer, doubkle-click the drive, then try to open My Documents, all I see is Loading bars/hourglasses all over the wondow. If I open a new window up (like, if I try to access My Pictures from my Start menu), it just shows loading/working symbology. It’s as though the HDD itself is slowing down my Windows processes. But, ONLY Windows components. If this infinite-loading issue is happening, I can open, say, Firefox and surf the web, no issues.

This has the signs of a failing drive… but I just don’t know. I can still access it (kind of), as in I can still see it. I just can’t get to what’s inside. Any advice/help/tricks/"try this out"s/remedies/solutions would be greatly appreciated. I know the end result boils down to “send it to a data recovery plant”, but I really wish to try all avenues and exhaust all troubleshooting attempts before I reach that bottom line.

Hello there, welcome to the community.

Try running the WinDLG software to test the drive, this can be found here, test it out and let us know the outcome.


I have WD My Passport Ulra 1TB and I have a similar problem with it. I have stored all my photos on it but now I cannot access the files. I can see the folders and even the files but I just cannot open most of them. Some open after a very long wait. I have tried another USB cable ( as we have another My Passport but no luck. I have done the WD Drive Utilities tests and it only passes the smart test. The other 2 tests it fails. What can I do, I cannot afford to lose all my photos.