My Passport Ultra 1TB Failing to load

Having seen other posts here and elsewhere i can’t say i hold out much hope of a solution but if only to flag the problem yet again as this seems like a major flaw somewhere if this is happening so often?

In our case the business purchased two 1TB Ultra’s to transfer files between sites. One of these devices has failed. When connecting it to a PC (Windows 7) a disk(E:) repeatedly tried to load (once every second), very rarely succeeds (happened twice in around 100 attempts!). If the drive becomes visible then i can see but not access the files on the disk as the ‘load skip’ interrupts any action before it completes.

I can only conclude that while the dis and data are fine something has gone wrong with the WD virtual CD 0830 which as far as i understand it seems handles load/security of the storage disk.

I have tried;

  • running WD utilities (“SMART status failed”)
  • a different cable to no effect.
  • connecting to different PCs, no effect
  • clearing details from the USB hub, nothing
  • changing the device policies, nada


Can you please share with us the model number of your drive? I’m a bit confuse since the My Passport Ultra does not come with a virtual CD.

Could it be a conflict with any other device or application on your computer?

Hello, thank you for your reply.
I think a conflict is unlikely as the same problem occurs on at last 3 different Windows 7 PCs, 1 Xp machine and a Windows 10 laptop. While those machines run the second identical unit with no problem.

I assumed the virtual CD drive, which also appears for functional units though is never visible as an actual CD drive as in the image, is the loading partition which contains WD software and security?