My Passport Studio, Firmware update and Mountain Lion


I have 2 issues:

  1. Like many other people when Mountain Lion goes to sleep the drive disconnects.  This is horrible for me (more than just a hassle) as I run virtual machine on the drive and just pulling the drive on a virtual machine crashes it at best and corrupts it at worst.  I have the settings in Mountain Lion to never sleep external drives and the same setting on the drive itself with the WD utilities.  My Passport Studio doesn’t use smartware, but I have it encrypted with the WD Security.  When I wake Mountain Lion from sleep the drive will appear to be connected but all the folders are blank until I manually run the WD security and sometimes need to reboot the entire mac just to get back to the drive.

2.  I see there is new firmware on the website however even when I choose my correct drive (model number etc) on the download when I run the firmware update software it says it is incompatible with my drive.  I tried on my windows machine as well (in the past firmware updates on Mac would not recognize the drive but windows would).


Are you using a USB or firewire cable to connect the Passport? If you are using the firewire cable, try using a USB cable and try again.