My Passport SE for Mac 1TB not reading in MacBook Black OSX


I have a “My Passport SE for Mac 1TB” external hard drive.

I use a MacBook Black OSX 10.6.8 Snow Leopard

Few days ago my hard drive worked fine when suddenly an error appeared that it can’t be read. It unmounted by itself and I unplugged my device.

I plugged it back using the USB connector and the LED light is blinking, I can feel something running it the device with a light noise inside. Waiting for the WD Smartware app to open but it didn’t and the Device that should appear in my desktop did not open. I did that for like five times and nothing happened.

I rebooted my computer. Plugged the device and it still nothing is popping out. Even in disk utility, nothing.

I tried it out in my other Windows OS Laptop and nothing.

I bought another Cable in CD-R King for assuming that my cable is broke and still nothing. It just runs something inside the device and LED is just on.

Nothing is popping out. Its not reading. The computer is just giving energy to turn it on.

Please. Someone reply!

Try updating the Firmware on the Windows laptop and then connected to your Mac computer, this has work for me in the past.

How can I do that if its not appearing in the Windows Laptop too?

Even when the computer is not recognizing the drive you can download the Firmware and see if the updater will see it.

If it does follow  the steps on upgrading and then connect it to the Mac.

I recently bought the same drive 30 Aug 2011 and found that the drive seemed to log itself out after 10GB. Time Machine failed. So having read the forum posts, I updated the firmware and installed the new SmartWare v1.3.3.8.

Am using a MacBook running Leopard 10.5.8 and yes, I have swiched off the sleep timer. Tried different ports.

After update, I still found that when using the password protection, the drive caused TM to fail or just crawl with a very very slow rate of data transfer. I then registered the device as a preparation to start asking “what to do” and was surprised to see the data transfer rate suddenly pick up … sadly that was for only 28 GB. Then it was back to a snail’s pace. Drive/computer was not moved so seems this is a software issue. I also tried removing the SmartWare altogether - no change.

I asked WD Customer Help who took several business days to answer but they offered only the firmware/software updates as a solution.

Having wasted several valuable days to get this premium product to work, it seems clear that WD should not be selling this as “Mac compatible”. Hope to be able to get a refund !

Update - as the nice lady from WD Help pleaded with me to try the fast formatting software.

As asked … I have again redone the firmware and downloaded the fast formatting software MacWDQuick_Formatter_v1.0.0.5

Prior to installing & running that I ran the update WDDriveManager2-26b … that allowed drive to run to 377 Mb of 202GB of the Time Machine before dropping to again to a snail’s pace. I tried restartng the Macbook and this time the TM ran to 1.4 GB before slowing.
I then ran the quick formatter (no choice about partition or format) and ran TM which immediately failed. I restarted the Macbook and again TM failed so we can assume that one should avoid the quick formaatter as a solution !

I then partioned the drive (350GB My Passport + balance for TM) and left format unchanged as Mac OS Extended (Journaled) using the Apple Disk Utility

After restart drive has again run to 1.4GB before going into crawl mode

I have then read many more forum posts on the subjects and one has to admit that there are an equal number of problems with TM running slowly especially on the first run. After further attempts the TM has now progressed with a “normal” transfer rate and has quickly reached 20GB with fair data rate of about 17 Mb/sec … what I have done then is a mystery. I did delete the contents of the new external drive which I had created so perhaps when I did that I also removed some invisible files (WD Smartware ones ?) which were interfering.
I am also monitoring the CPU use by Finder - had seen a thread suggesting that by relaunching Finder one could unlock the “pipe” so to speak - but it appears calm and is not hogging the CPU.
Well … it appears to now work but all this effort makes me feel very very insecure. Not the sentiment one is supposed to have by buying WD ! Feel like making a second backup using someone else ! :slight_smile:

Morning … and more problems.

This “My Passport”, I guess like many users, is partitioned. Whilst TM has sorted a backup of the Leopard side of my Macbook, I am obliged to fall back to a trusted Retrospect for the Tiger side. I watched the backup as far as 15GB of 106GB and carefully leaving my Macbook set to not sleep with mains connected, left the process to run overnight.

As soon as I was out of the room, the My Passport went to sleep. Great.

SmartWare at work again I suppose although I thought that I had disabled all that.

This really is a completely rubbish drive for Mac users. WD if you build a drive for WIndows users, please don’t also market it as Mac compatible.

It is not - if only one can see these forum comments about all the problems then I would have never bought the wretched unit.

Check out my eBay when I get back from this next trip … there’ll be a My Passport 1tb going cheap