My Passport now is 439 GB after running Swissknife to reformat to FAT32

Just bought a My Passport Friday to use to store video from Sony video camera.  When I tried to export video to the drive, it said it had to be formatted to FAT32.  Not knowing what that meant, I went to WD support and was directed to 3rd party software.  After spending hours trying to find good software to reformat, I chose Swissknife.  After running, it did reformat butt now it shows up as having only 439 GB!  I went back to my computer and reformatted back to NFTS, but still shows only 439 GB.   Haven’t had any luck reinstalling drivers.  Any way to turn back the clock and make this drive like it was when it came out of the box, or is it toast?

What’s the drive original capacity? 

It was originally 1 TB (actually 935 GB).  Any ideas would be appreciated. 

When you formatted did you delete the partition/volume? Not doing so can cause errors. Did you try formatting NTFS from Windows? Here is a refressher for formatting

1 Like

Joe, thanks so much for your help in providing the link.  It worked perfectly and now my external hard drive is back like it should be!  Thanks again and have a Happy Thanksgiving!