My Passport not mounting on MacOs Ventura

Since the latest macOS update of Ventura My Passport has not been able to mount onto my MacBook.

The WD HD My Passport was mounting perfectly fine, prior to updating to Ventura. Now I’m getting errors.

There was a new update to Ventura 13.4.1 that I updated today. I thought this may solve the problem, however it has solved nothing. This issue is frustrating. This is also the third time this has happened with a Western Digital product. I shall not be buying any more products from Western Digital and this seems to be a constant problem.

Anyone with ideas on how the WD My Passport for Mac will mount and back-up my data. Please feel free to give advice. I was only made aware of the My Passport not backing up when I saw the notification, ‘You haven’t backed up in the last 10 days’. My Passport was set-up to back-up automatically, hence I did not realise my data was not being backed up.

Screenshot 2023-06-26 at 19.39.42

The error message you encountered, “Could not mount ‘AppleAPFSMedia’ ( error 49218),” indicates an issue with mounting an Apple APFS (Apple File System) media. This error typically occurs when there is a problem accessing or mounting the APFS volume or container.

Here are a few suggestions to help you troubleshoot and resolve the issue:

  1. Restart your computer: Sometimes, a simple restart can resolve temporary glitches or conflicts.

  2. Check the disk’s health: Use Disk Utility on macOS to check the health of the disk. Select the problematic disk or container in Disk Utility, then click on the “First Aid” button and follow the instructions to check and repair any disk errors if possible.

  3. Verify the disk’s permissions: In Disk Utility, select the disk or container in question, then click on the “First Aid” button. This time, select “Repair Disk Permissions” to verify and repair any permission issues on the disk.

  4. Try using the Terminal: If the above steps don’t resolve the problem, you can attempt to mount the APFS media using the Terminal utility. Open Terminal (found in the “Utilities” folder) and use the diskutil command to mount the APFS media. Here’s an example command: “diskutil mount disk2s1”
    Replace disk2s1 with the appropriate identifier for your disk or container. You can find the identifier in Disk Utility or by running diskutil list in Terminal.

  5. Use macOS Recovery mode: If the disk still cannot be mounted, you might need to use macOS recovery mode. Boot your Mac into macOS Recovery mode and use Disk Utility or reinstall macOS to fix the issue. Be aware that reinstalling macOS will remove all your personal files and applications unless you have a recent backup.

However, in case of any data loss, try using data recovery software such as Stellar Data Recovery to recover your crucial data from the storage device.

If none of these steps resolve the issue, it’s recommended to contact Apple Support or visit an Apple Authorized Service Provider for further assistance.

I cannot mount my new passport for mac. I am on Ventura 13.6.I read on Internet to not us APFS for any system not Big Sur. or later. So I tried the other one below APFS

I am also on ventura 13.6. My new passport replacement will not erase which I need to do to use it as a backup for my computer. I tried same settings you did. I get error message the disk cannot be removed. I’ll call WD if I do not get an answer from this forum. I am miffed right now. I tried a different setting. That did not work either. Did you ever figure out what happened with your ext. disk?

I’ve given up on WD products as this issue of a disc not mounting has happened around 4 - 5 times. The issue arises when there’s a new update to the OS (I use a MacBook). Every time there’s an update, there’s issues with WD products mounting and has resulted in lost data/work. This is 10+ worth of work and 5tb+worth of data.

I’ve bought Seagate products instead and there’s no issue with the disc mounting when there’s a new OS, including the newest 14.0 (23A344).

Thanks.I’ll probably try a different brand next time. I have to WD external drives. One was a replacement.The other doesn’t always show up but tonight when I held the cord higher near the part where it goes into the computer, it then showed up and after awhile I could let go and it stayed on the screen. It is out of warranty so I cannot return it now, but I did return my other one and got a new one which so far is working great. WD is really more of a windows company. I knew that but when I got the Passports I didn’t notice at first that they were a WD product.

I have had the same issue on my WD Passport USB SSD I have at my office that I’m using for Time Machine. Works for about a week or two then won’t mount. I have to erase the drive and start over again. I’m going to pay more attention to if this happens after updates. Very annoying to have to go through this constantly. Oddly, I have a WD Passport USB HDD at home for Time Machine and it never has an issue.

I erased my drive but can’t get it to work now. What did you do after you erased the drive?

Download and reinstall the WD Discovery software from the official Western Digital website. This software provides additional tools for managing WD drives.
If all else fails, you may need to consider data recovery options. Professional data recovery services or software tools like Stellar Data Recovery, Disk Drill, or EaseUS Data Recovery Wizard might help recover data from the drive.

@Thomas_Shillingford Having same problem. Any update on how to resolve it? :slightly_frowning_face:

@DaveDouma, my issue wasn’t resolved, and I ended up losing ALL my data. The only advice on the WD website is to engage with a vendor who could retrieve the data—at a huge cost.

I refuse to buy WD products anymore due to the updating issue. I have bought Seagate and have had no issues.