My Passport no longer shows on Windows Explorer

After successful use for several months, first intermittently, and now never, the My Passport 1 TB drive does not show on
Windows Explorer.  I tried changing USB cables and tried plugging in different USB ports, and rebooting.  I can’t access the drive.

First of all you have not encrypted the drive with a password, have you?

When you open Computer, the drive doesn’t show up when you plug it in?

Have you tried looking for the drive on Disk Management? (Win7)

Go to Start menu, right click on Computer and choose Manage, then find Disk Management in the left-hand menu. If it reports that your drive is recognized but not initialized, don’t format unless you want to lose all of the data stored on it.

If it shows up here then there are several free programs you can use to recover your data before formatting, then hopefully the format will solve the issue. Let me know how it goes.

1 Like

Thanks for your reply!

I have not encrypted the drive.

When I open Computer the drive does not show up.  The light on the My Passport drive lights, and is on steady, not flashing.

When I right click on Computer and choose Manage, then select Disk Management in the left-hand menu, the My Passport drive is not on the list of drives.

Have you recently done anything to the drive that may have damaged it or installed any new software? Does it show up in the device manager?

1 Like

I did take it on a trip recently, but it was with me in my computer bag the entire time.  It did go through the x-ray machine at the airport, but that never has caused me a problem with any of my computers in the past.  However, it was when I tried to use it in the hotel that evening that it started to act up, and only backed up a portion of the directories I wanted to back up.  Then it stopped working altogether.

It does not show up on Device Manager.  I purchased two of the My Passport drives, both 1 TB, both identical, at the same time.  The one drive still works just fine.  Its this one that used to work, and now doesn’t.  When I plug in my other My Passport drive, I get the alert sound from my USB port that something has been connected, and a window is launched automatically that allows me to select an option that launches Windows Explorer showing the My Passport drive contents.  When I plug in the bad My Passport drive into my USB port, I get nothing.  No alert.  No window is launched.  Thanks for all the feedback you have given me so far.  I appreciate.

Well if you can’t get the computer to recognize that the device even exists I would say your last option is to burn a Linux live cd ( and boot the computer with the disc in the drive, wait for it to load, and choose the test option, then see if your drive shows up in Computer as a filesystem. You might be able to pull data from it if it shows up.

1 Like

Thanks for all of your help.  The data on the My Passport drive is all back-up data, so I don’t neet to read the disk.  I am reluctant to send the disk back as an RMA because all my financial data is on the drive and I now have no way to delete it.  I’ll have to decide between getting another My Passport, or going with a Seagate equivalent.

I think it would still be advisable to try to access the data if possible to delete it to prevent a possible security breach. If it’s worth your time then go for it, you never know what you’ll learn by tinkering around with things. At least now I know it’s not a good idea to put a drive like that through a security scanner.

1 Like

One other possiblility is a faulty cable, but given what you’ve described it seems that it’s unlikely to be the problem. If you have access to a replacement, you may as well test that out to be 100% sure you tried everything you could to fix the problem.

1 Like

Thanks for the tip,

I tried the cable that came with my other My Passport, the one that works, with the one that doesn’t.  It didn’t help.  Drive is still not recognized by USB host in my laptop.