My Passport Just Stops Working

Every My Passport I’ve owned has stopped working and I then need to buy a new one.

I cannot even figure out how to open the settings.

I have all my files up to January this year and nothing new since.

What is going on with these things?

Thanks.

Why don’t you post your MyPassport Model # (approx Purch date) and whether you’re using Latest Smartware or WD Backup.
No one knows what they’re addressing so far.

I couldn’t get 2015 MyPpt Ultra AND a New 2018 MyPassport to work with Smartware. Had to Uninstall S’ware & install WD backup and the New worked immediately;

The 3 Yr-old Ultra took awhile to get going. Preparing backup would spin for 2 min but no evidence of backup occurred. Note your Backup Files location Changes going from Smartware to WD backup (if you do/did) so don’t first look in the old Smartware Folder for changes; They’re In the New WD Bkup Folder IF they occurred. WD Backup showed the Ultra Offline BUT after Clk’ing on the Ultra icon “Add a Backup Plan” finally worked after a first try Error. When changing Drives I get an error about the Drive being recognized. I Clk the Icon and then “Do a backup now” and all is well.

Phone Support in the WD Backup setup “Include: Edit Files” remotely checked ALL the boxes in Library that I had Not Chk’d because I Chk’d essentially the same Folders in the My Computer module. I did not witness any Recap of File backup (1.6 GB) UNTIL he chk’d the Library boxes. I went in to My Computer and Un-chk’d a few boxes in Documents, but it’s been doing Hourly Checks/Backups since. Cause or Coincidence, I don’t know.

I’ve read USB A to Micro B cables can go bad over time; Not likely your issue but people post it’s happened to them.
Scroll down Pg (after WD Backup Dnload) for all Software IF needed. Links are in the blue-border rectangles.

Open Support case

Update your data and hopefully you can get help.

1 Like

Thanks. I did the back up and have the Backup the file now.
Will check it later.

Model # WDBBEP0010BBK-01.

Put in service on JUNE, 2013.

Windows 10

The Backup file takes me to a file .metadata and stops there.
Do I need to wait an hour for the backup to run?

Hopefully, Clifford Cleary will see this and Help us.
If Preparing Backup is still spinning then, yes, you have to wait.
I’m not techie enough to know what you mean by “The Backup file takes me to a file .metadata and stops there”.
My Backups on my Ultra are found via the Path: [ J:\WD Backup.swstor\My name\VGMgOJUGO1NdHDOj\Volume{a1bbc16f-7361-11e1-9521-806e6f6e6963}\Users\My name\Documents\Craig.

IF you mean you installed WD Backup and Clk’d “Backup Now”, then in Win 10 you’ll have to Browse to the “similar” Path I had to use to find my Backed-up Files. My path is for Win 7-64 but you get the idea of how to Browse.

Update when relevant and maybe Clifford will chime in, too.

1 Like

The back up is now complete.
File paths extended same as yours.
Resolved.

Thank you.

Good Job! Help others when U can.
Good Luck!

1 Like