My Passport is not recognised by my PC win 10


#1

I have just purchased a new My Passport 4tb portable HD. When I insert the USB cable into a USB port it is not recognized. I do have another brand of portable HD as my backup. Even when I disconnect this other devised, reboot the PC, the new WD is not recognized. I am running Win 10+ 64 bit. Can someone offer a solution, thanks


#2

It is called DOD. Return it for a replacement under DOD terms.


#3

@Lifechip Check this to see if it will help with your problem, if it is not already selected.


#4

I’m a Mac user, but you might have similar options on Windows 10. Since your new ‘My Passport’ 4tb portable HD is a new drive, it probably isn’t formatted for windows 10 - you might try using Disk Utility.app - it could be located in Applications folder and then the Utilities folder (I’m assuming windows folders might resemble Mac folders) - After you have opened the app, in the Disk Utility window, click on the ‘My Passport’ to highlight your new drive and then from the top tabs choose ‘Partition’ the next window has a line that has Format: on the left, on the right, click on the little arrow down and it should give several formats to choose from - since I don’t have a PC, I can’t give you the choices, but see if Windows 10 is listed - Anyway, it won’t hurt to check it out and see if you have anything that looks similar so you can format your drive to work with your Windows 10.

I’ll explain for Mac users a description of a new ‘My Passport’ Ultra 4T drive fix that gave me an error when I was reformatting it:

Using Disk Utility I was able to fix the problem of my Silver (Gray) ‘My Passport’ Ultra backup drive that in the process of getting it formatted for Mac from Windows it gave me an error and the name had become ‘disk3x2’ or ‘disk2x2’ instead of ‘My Passport’ - Disk Utility was the only place I could see that drive at all) and it would not mount – fortunately I had purchased two of the same drive, and the first ‘My Passport Ultra’ that is blue had successfully formatted to ‘Mac OS Extended (journaled)’ - I ran ‘first aid’ (a Disk Utility feature) on my Silver (gray) drive, and chose that (blue) drive from the options rather than my computer hard drive (the only other option) and the ‘first aid’ tool copied the blue ‘My Passport’ Ultra drive to the Silver (Gray) ‘My Passport’ Ultra – however, after the first aid was finished, it named the gray ‘My Passport’ Ultra drive the very same as ‘My Passport’ blue drive, I dismounted the blue drive that was working properly (it was listed on the bottom, and that was the only way to identify it), and then I ran the ‘Partition’ again on that Silver (Gray) ‘My Passport’ Ultra 4T drive – I actually had to run a different format on the drive first in order to enable me to rename it (I happened to choose ‘ExFAT,’ but I don’t think it would have mattered which one I had chosen), and then I did the ‘Partition’ again on the gray ‘My Passport’ drive and since it was already renamed the way that I wanted it, I just chose the format to be ‘Mac OS Extended (journaled)’ - it didn’t give me the error message this time and the icon showed up on the desktop of my computer – I am so relieved that it is fixed. I’m able to copy files to it – I guess it is fortunate that I purchased two ‘My Passport’ Ultra drives at the same time. There might be another way to fix it after it had an error during the first partition (reformat from Windows to Mac), but I hadn’t found it and I was getting ready to send the drive back to Western Digital. I’m glad that I tried the ‘first aid’ option, and that I had a working drive just like it! (Maybe I could have copied the computer hard drive (only a 650 GB) to the gray ‘My Passport’ Ultra, and then do the ‘Partition’ again to ‘Mac OS Extended (journaled)’ but I’m glad I had the other option, and that it worked!)