My Passport for Mac suddenly not working


#1

I have two 1tb My Passport external drives. I keep one at work and one at home, as double redundant backup, as well as to store videos since my Mac only has 500 Gb of memory.

One of the drives is suddenly not showing in Finder. Since I have two identical drives, I tried to reformat the non-working one but keep getting a message saying the operation could not be completed. Does anyone have any suggestions?

My OS is Sierra.

Thanks.


#2

Hello gerbear,

This would cause when data is being used in some background running process or by antivirus or applications. Please make sure to close the unnecessary running applications using the same drive content and then try to format.

Moreover, you may run First Aid test to fix partition issues. Then try to reformat the drive with appropriate file format.


#3

Hi asp73. I tried reformatting but my Mac isn’t even recognizing the drive. I tried changing cords and USB ports in case there was an issue there, but still nothing. I will try the First Aid test this evening.

Thanks.

Gerbear


#4

I have two identical WD Mypassports. One of them works just fine. The other one is no longer recognized in any way by my Mac (OS 10.12.6). I can’t reformat or try first aid or anything else, because my Mac does not even know it is there. I tried changing USB cords and ports, but nothing. It’s like it is not even there. No icon, nothing in finder, nothing disk utility – nothing. Is it the MyPassport? It’s about two years old and I only connect it about once a month to back up my Mac. Does anyone have any ideas?