My Passport Essential


#1

Ok to start off i read a few topics around here and i noticed some stuff. So here is my discription.

I bought my passport essential 640gb about 2-3 months ago. When i made the purchase i knew it was a fragile item. I tried not to drop it. And i succeeded… almots. Dropped it only once from not too high. Cant recall exact hight. Anyway. I dropped it. Picked it up and plugged it back in to check if its ok. Wooo hooo everything is fine.

I move it a lot. 95% of the time its not working while moving it.

Here is what i think might be the problem, which does bother me cause the same happened with my wi fi.

A few days ago i had to switch from windows to linux for a little bit and needed some data from the external hard drive. So i plug it in, get the data and remove it (not with safe remove). Today i plug it in and no computer recognizes it. The strange thing is that in linux (ubuntu) it works abso-efing-lutely fine. But in the buggy sh-beep-y windows it says its corrupt and unreadable. PLS HELP. Im out of ideas. Except to clear any space i can and copy everything through ubuntu (but thats around 100 gb of data on the ExtHD), format it and copy all the data back on it. Please help me. Thanks in advance

-TheScarecrow


#2

I would get the data backed up.  Download DLG Diagnostics from our Downloads page under your product, and do both the quick and extended test on it.  It will tell you if there is any physical damage to the platter(s).  You will need to do the test on a Windows machine, but DLG Diagnostics should see the drive.


#3

Ok what i dont get is if the drive is actually physically damaged how come ubuntu can find it and work the data how ever i want it to. Doesnt make any sense.

I had the same problem with wi-fi. I hook up to it with windows then switch to ubuntu then back to windows. When i get back to windows the network just doesnt want to hook up. No error message no nothing. Just doesnt connect. Then i figured out that the router actually remembers that i use ubuntu and when i try to connect with windows it doesnt let me. The solution to that problem was to restart the router 10-15 times or just disconect from the network within ubuntu.

Also how can i back up the data now? Through Linux? And this diagnostics program, what will it do? Just find the drive or actually let me back it up/fix it/other stuff?

Thanks for youor quick reply.


#4

You dropped it!  I have no idea what kind of damage it has, or whether it was even damaged.  But because you dropped it, I wouldn’t trust how long it will last, before it gives out.  It may last forever, but no matter what, you should have all your data backed up somewhere else, anyway. 

The reason for using our diagnostic utility, is to see if there was any immediated damage done to the drive.  The utility will check the surface of the platters to see if there are any bad sectors.  It won’t fix anything, except maybe mark off the bad sectors, so your os won’t try to write to them.


#5

I couldnt find the DLG Diagnostics anywhere on your site so i googled it. I found a version 1.09 and a 5.3 something. I tried both and both said that i havent inserted a diskette in the drive… Tried all my usb ports with both versions every time the same thing. Can you give me a direct link. Also the wd firmware that i have installed on my pc (that monitors temp. , capacity etc) doesnt show the drive but lets me safely remove it. Im no computer guru but that is really strange.


#6

Download it here.

http://support.wdc.com/product/download.asp?groupid=608&sid=3&lang=en


#7

Test Option: QUICK TEST

Model Number: WD My Passport 070A

Unit Serial Number: W**********4

Firmware Number: 1032

Capacity: 639.43 GB

SMART Status: PASS

Test Result: PASS

Test Time: 11:02:00, August 06, 2010

The extended test will take 10 hours so i gotta wait a bit x_x

Again thanks for the fast response bill_s ill post the results from it when its done. In 10 hours 16 mins…


#8
Test Option: EXTENDED TEST
Model Number: WD My Passport 070A
Unit Serial Number: W ********** 4
Firmware Number: 1032
Capacity: 639.43 GB
SMART Status: PASS
Test Result: FAIL
Test Error Code: 08-
Test Time: 22:21:52, August 06, 2010

Ok so these are the results from the extended test. It wants to repair something but i still dont have all my data backed up. I need around 80gb free space on my laptop’s hard drive. So does this tell you anything or i shouldve clicked repair? All i want to know is can i use this ExtHD still. Once i back up all my data i will run the extended test again and ill click repair.


#9

If you’re using the correct length of cable for the Passport, and the failure is due to too many bad sectors, I would definitely replace the drive.


#10

Well im using the cable that came with the drive. Im still waiting for my dad to come back home. He has a WD My Passport Essential 500gb so he has some spare space. I’ll back up my data. And do the complete erase. And try to repair it. When thats over with and its not working still ill take it to a technician. The drive is still in waranty ( i might not be saying it right) so he can do his tests.


#11

Wait. Now that i think about it the drive worked fine until 5-6 days ago. A few days ago i wanted to transfer a few hundred pics from my very very very very very… very old pc (around 5-6 years if not more). But the pc just glitched in the middle of the copying. Mouse didnt move. Keyboard didnt do anything. So i had to restart the pc manualy. When i did that and plugged the ext hd it glitched again. So i tried other pc’s but the drive wouldnt open it. Could it be that the ExtHD is still trying to copy those pics?

Edit1: Now when i plug it in it starts making a beep sound. Every few seconds.


#12

Or, the partition/files have been corrupted.  That could have happened easily if it was in the middle of transferring files.


#13

Yeah it was about half way done with the transfer. And the computer just froze up. Before manualy restarting it i waited like 5-10 mins to see it anything will happen but nothing did happen. So i had to restart it. So thats the problem huh?


#14

Check to see if the drive shows up in Disk Management.  If so, then you may try finding a partition/file recovery software to see if you can restore your data. 


#15

Disk Manager finds the disk. But when i run a recovery program i see only the deleted files. I cant see the other data i need(but ubuntu can show me the data i need. So i can recover it from there). Also in the deleted data i found the folder that caused everything. But i cant delete it.

I got an idea. Since ubuntu finds the drive i will go in it and create the folder that got deleted. With the same exact name. Maybe that could fix it.

UPDATE: That idea didnt work. Ubuntu finds the drive, lets me copy files FROM it to my internal HD but doesnt let me copy/create files/folders in it. So my inicial idea to copy my data through ubuntu and format the drive is the next idea.


#16

Hopefully, that works.  Unfortunately, I don’t know enough about Ubuntu, yet, to be of much help to you. 


#17

Mine is hardly a month old, took great care and not dropped. I encountered this problem today.

Was working fine and have entrusted all my previous files in the past week to it because I was afraid my 5 year old iomega will fail soon (though still wokring).

Today while saving some photos from my digital camera it suddenly hanged, with message like … writing error due to connection problem.  Reboot the system.  The drive cannot be detected since .

Called support helpdesk, who then told me there have been many such instances and guided me through to update my firmware. But I cant install the new firmware when the computer cant even detect the drive, though it is operating (from the blinking light and sound). Their solution to me is to visit their data recovery partner, who quoted me a bomb to recover the data. That’s when I try searching the web for solution and discover all the shocking bad experiences here. 

So frustrating, having all my years of precious files and photos in there.  And I chose WD because I thought its a quality brand.

Is spending 4 digits on recovery services the only solution?  Could they at least try to test it physically? 

Maybe there should be legal obligations on storage companies as the cost of data lost is getting higher nowadays, to discourage substandard products.


#18

My only advice (from a non expert, not techno savvy guy) is to find a live version of ubuntu (it can be put on a cd or an usb flash drive and run without installing it) and see if you can locate the drive and get your files. Ive found that every problem i have with windows i dont have in ubuntu(except in this instance where i cant create or delete files on the ext hd drive). But ubuntu doesnt support the games i play or the photo/video editing software i use.


#19

put the disk in anoither computer and see the system file, NTFS, fat32, etc…

for NTFS and FAT32 you can recover all your data in a damaged file system or, formated disk, etc,

the program name is GETDATABACK, google it a while :slight_smile:


#20

Well what i have found out after 3-4 hours of waiting for windows to format the drive (and failing after that) then waiting another 6 hours to format it through the wd data lifeguard (and failing cause of power problems) then waiting another 8 hours for wd dlg to complete it its now working good as new. I managed to save my (now) 63gb files. Hopefuly i wont have to repeat that again any time soon.

Thanks for all the help bill_s.