My Passport Essential SE...broken?

I have a My Passport Essential SE, WDBABM7500ABK, and I was copying some files, when something happened…the files didn’t get copied, they got stuck. Everything was frozen, I couldn’t disconnect the Hard Drive properly, I couldn’t abort the operations, nothing. So i disconnect the cable, and waited 10 seconds, and I put it in again. Nothing. I can’t see the Hard Drive Anymore…even with the disk utilities, I can’t see it. 

I can hear the hard drive spinning, the light is on, but nothing. I used it on my Mac Leopard, but I tried on a PC too, even with my Boxee, but nothing. Is it all gone? Dead? Over?

Hi there, what if you try a firmware update on a PC? It works most of the time to bring it back to life.

Best of luck!

I just tried to plug in My Passport, S/n [deleted], in order to run Time Machine.  I’ve had no trouble in the past doing this.  But today, my MacBook Pro does not “see” the Passport.  Does not show up on the Desktop or in Finder.  Is there some way to fix this, short of junking it and getting another drive?  I have no other back up files!!  I don’t keep the Passport plugged in all the time, just every week or so.  The Passport has not been dropped or otherwise mistreated.  

Please, someone help!


I should add that my next backup will be about 304 GB in size and the Passport is only 250 GB.  Could that be the problem with my MacBook Pro not “seeing” it?

Well, I found out by clicking around on this site, that sometimes the USB cord’s small end does not make good connection with the drive.  Even if the drive’s light comes on and it sorta vibrates like it is working, it isn’t properly connected.  So I pushed it in further, held it tight, and lo and behold – my Time Machine “saw” the drive and began the backup!  Perhaps WD shoiuld fix this connection issue in future hardware?!  Duh!