My Passport Essential not recognised by new ASUS laptop

Hi there,

I am using the external harddisk ‘WD My Passport Essential SE 3.0’ (WDBACX7500ABK).

Now I have bought myself a new ASUS laptop (Asus N76VB-T4039H) with windows 8 running on it.

When I now try to connect my harddisk to my new laptop it is not being recognised (tried all 4 USB ports).

The harddisk work perfectly fine on other laptops (so no hardware/cable problem I assume).

The laptop also normally recognizes other USB devices (so no USB port problem there I assume).

I have already tried rebooting the laptop and I tried installing the WD drivers again (

Nothing however seems to work. I really need to connect this harddisk to my laptop.

Please advise. Thanks!

No one? I am pretty desperate as I need files on the HDD.

In device manager the HDD is not displayed. When I turn on the ‘show hidden devices’ it shows up on the bottom of the list. I again tried to update drivers, but it says I have the latest version already installed.

In disk manager the HDD is not displayed at all.


Really no one can help here??? Cannot imagine as this THE WD forum…

Just say if it is too complicated or too generic to help me from here… If known I can go find myself somewhere else a solution.

Hi Jankees, sorry for the delay, have you tried checking if the Passport is recognized in the Disk Manager window? If you can see it there, try adding a drive letter to it. Check the link below for the steps.

How to change the drive letter assignment in Windows 7, Vista, XP or 2000

If it’s not recognized, it is possible that theLaptop is not providing enough energy to make the Passport work correctly. Be sure to use the USB cable that came bundled, since longer cables can cause power inconsistencies.  

ASUS has admitted fault in some cases like this where a BIOS flash upgrade is necessary to recognise USB 3.0 devices.

Please realize that someone here not being able to help may not be the fault of those here.

Your device works on other systems, which means it’s likely not a WD problem, but rather an ASUS problem.

You should be looking in the ASUS forums about this, as someone there is likely to be able to tell you exactly where to go to get the update you need for your exact model of laptop.

I will provide this possible solution though.

It’s also quite likely that the USB ports simply aren’t providing enough power.

I recommend that you get a POWERED USB hub, and plug the hub into the laptop, and then plug the drive into the powered hub.

Some powered hubs don’t come with the required power adapter (because they do work without them, just not for high current devices) so make sure you have the correct power adapter powering the hub as well.

You can also sometimes find USB cables that have 2 male heads for extra current situations like this, but they tend to be hard to find.


Will have a look at it.

Would a BIOS upgrade affect any other setting etc?