My Passport essential 750gb not 'unmounting'


#1

Hello there,

i recently bought the WD 750gb My Passport Essential SE. I’d backed up about 200gb of data on it. A few weeks later I had transfered some data to a friends mac, when i came to using it on my own macbook pro again the drive is recognised in finder and disk utilities but i cannot access any of the files on it, and makes them appear as if they are not there. 

I have tried most things, particularly partitioning it to start from scratch, however the same error message comes up ‘Could not unmount disk.’ I have tried a few things, such as making sure the drive isn’t password protected or locked but so far no luck, any ideas?

Much appreciated, 

Dave


#2

Hey Dave, 

The very same thing happened to me as well with my 750GB passport. I have two Macbook pro’s and used my passport to back one notebook on it. I then backed up the second notebook on the same passport and now I am unable to log in with the original password I set by the smartware utility.

I decided to reformat the passport and attempt to back up again, however when I try to reformat the drive the WD Smartware utility crashes when I try to reformat.  I’m going to follow up with WD now, and I’ll keep you posted.


#3

Hey Dave, I came across this information. I’m going to try this out now.

http://acletras.com/2009/09/28/wd-smartware/