My passport essential 1 tb is Acting weird

Here’s the problem:

I’m using Win7 basic as my OS on Toshiba Satelite laptop and my HD is WD passport essential 1tb with 3.0 usb (compatible with 2.0).

At first it worked good and smooth. I’d been using it almost a year when oneday, out of nowhere, my laptop stoped recognized it. The letter drive was there, but no memory status bar. I tried to pull out the cable before plugged it back few times, but nothing happened. It was still unrecognized. 

The weird thing was, when I plugged it in, the PC kept telling me to format it, over and over again as if the connection was being pulled and plugged every 2-3 minutes (which I didn’t do).

I scanned the problem using data lifeguard diagnostic for windows, but the program was loading too long to recognize the HD. 

I thought it was because the “bad sector”, so I tried to fix it using HDD Regenerator 2011. The program recognized my HD, but when I tried to repair it, the connection of the HD suddenly turned off and on, so the HDD Regenerator couldn’t fix it because it kept losing the connection every time it tried to scan the HD. 

And one more thing, the WD was recognized in “safely remove” thingy on Taskbar. It was written WD Passport, but when I tried to safely removed it, it wouldn’t removed.

So what do you think is wrong with my HD? Is it because the cable? Or something else?

I really don’t want to format it since all of my lifetime files are in there T T

Try using the short USB cable that came with the Passport and then use a data recovery program like recuva. If that doesn’t work then probably you need to replace it.

1 Like

I had tried to change the cable with the same USB 3.0 from my friend’s WD passport, but it didn’t work. So I gave it to an expert to fix the problem.  He said that my Passport probably was being damaged inside (hardware) by an unstable electricity because it couldn’t be detected by his recovery file program, even thought no clicking sound could be heard inside the HD. So now he’ll try to retrieve the data by breaking the case open. Hope it’ll work, even thought that could mean I’ll lose my WD Passport. I don’t care as long as my files are back.

But…of course I want to thank you for the time you had spent to gave me response of my problem. I really apreciate it :slight_smile: