My Passport 750gb not going USB 3 speed

I bought a WD My Passport 750gb USB3/2 portable drive, and after plugging it in to the blue USB3 port, I got the “This device can perform faster when connected to a Super Speed USB3 port”. I’ve tried both ports, same message on both. I uninstalled the old drivers and updated them with the newest USB 3 drivers, updated my BIOS, double checked all the settings in the BIOS, upgraded the firmware on the drive, installed Win 7 SP1, still no luck. I read in another post that said the Passport requires 900mA to have enough power to utilize the full speed of USB 3, do you by chance know if the EVGA SLI3 X58 Mainboard has the same under voltage issue? The board from the post was an Asus Mainboard. Any help to fix my issue would be appreciated. Thank you. None0099

I have exactly the same problem as you.

Done all the firmware updates (my passport 1 TB, usb 3.0 host controller on the MB, BIOS), but still no recognition by Windows 7 64bit.

When I plug the external unit in into my laptop, Windows shows the "This device can perform faster when connected to… " popup.

Tried both USB 3.0 ports.

It works only on the USB 2.0 ports.

You say that It may require a 900mA.

In this case I think it must be specified on the package before buying, as many laptops may have this problem.

In this case, there may be a double USB port to connect directly to My Passport (same as the external DVD burners) ?

I think your best shot is to reach WD support directly…

The real problem is USB was not well tested before release. I just read that on some PCs if you plug in a USB 2.0 device it will slow USB 3.0 to USB 2.0 speeds. I wonder if that applies to mice and keyboards plus the numerous built in card readers that connect with USB now.