My passport 500GB bricked/blocked or whatever

Hi everybody,

I bought my HDDlike 2 years ago and it worked like a charm since this summer.
I used it on my laptop which was plugged with the charger but no batterie. As I were in India and the electricity system there is not so reliable, I had to face a black-out, but a really quick one. I plugged the battery back into my laptop and since this moment my Passport refuses to work :frowning:

The computer detects it, I can see it when I use the secure unplug assistant " Passport 070A" but it doesnt appear in the Computer window. I can’t access it by any way. I tried to erase it with the windows management tool. but it says that the drive is in read-only access. I tried with WD Smartware. It recognises the drive and shows a small locker icon on it saying “the drive is locked”. When I click on it, it asks me if I want to erase, I click yes, it seems to work but nothing change in reality… I tried with the quick formater too but it says “failure”… I don’t know what to do…

A last thing, I can’t remember setting up any password when I plugged the drive for the first time and it never asked me to enter one… but in the Smartware window, its said that there has been too many attempts… strange.

If anyone could help me, that would be awesome ! I know that I certainly wont recover my datas but I would appreciate that my little Passport comes back from its ashes! 

Thank you per advance


if the drive is under warranty just replace it

the unit seems to have a partition issue

You can also attempt to update the firmware

Try a different computer and see if able to erase with Smartware

SAME behavior here i formatted it and no luck neither. i dont know if this is your same problem but mine is detected as 2047,3GB O.o And maybe after a sucessful reformat i could use some recovery software out there ANY LIGHTS SINCE THIS HAPPENED?

Well you can try recovering the files prior to reformatting

where is the drive detected, device manager or disk management?