My Passport 1TB & Playstation 3 connection problems

Dear community,

I created a second partition on my passport 1TB external harddrive and formated partition 2 with fat32. However my Playstation 3 refuses to “see” the drive. This is not the case with an older 500gig drive from Maxtor where I also created a seperate fat32 partition.

Would you have any suggestions what I can do to get it working on my PS3? I had used the program EASEUS.

The only thing that I can think of is to format the whole drive in fat 32 but I shouldn’t have to do that since it worked with the other drive as well.


Try formatting the whole drive FAT32 Then create a second partition for NTFS or whatever you want. It may only read the first partition data and stop.


Thanks. I’ll try that. Maybe I can also switch the order which partition loads first? I just play around with the program and chances are I will screw things up even more :slight_smile:

Ok so moved all the files around the partitions and in the end managed to convert the whole harddrive to FAT32. But the playstation 3 is still not recognizing it :frowning: Any ideas?