My N900 Experience

After reading quite a few favourable reviews I purchased the N900 product yesterday. I’ll be returning it at some point but wanted to most my experience so others having similar problems and/or thinking of buying this router would be aware of some of the issues I had. 

For background I’m configuring on a Mac OS X notebook computer via a web browser and I’m connecting the router to a VDSL2 modem (PPPoE connection) to TekSavvy in Toronto, Canada (same network as Bell Fibe). 

When I first booted up the router all worked as expected. The “WesternDigital” wireless network was visible and I connected to it, then browsed to The interface appeared.

The first thing I did was update the router to the latest firmware (1.03.1 I believe), which I had previously downloaded from the WDC site.

After the 300+ seconds the router was available again running the latest firmware and I began to configure it. 

The first problem occurred after I changed the LAN configuration. I typically like to use a 172.16.x subnet for my local network (old habit). I did so with no issues and the router rebooted. After the reboot, the administrative interface at 172.16.x.1 never appeared. The router was pingable at that address but attempting to connect to the web interface resulted in an immediate “connection refused” (verified via terminal and attempting to telnet to port 80). 

I power cycled the router but this didn’t solve the issue, so out came the paperclip and I 10-second reset the device and started again.

This time, I was able to reconfigure the subnet to 172.16.x and reconfigure the wireless network SSID / encryption without issue. So far so good after a rocky start. 

I then configured my PPPoE connection. This initially worked but performance was very poor and through browsing these forums I was able to debug it down to the FasTrack+ system. The autodetect was incorrectly detecting my upstream and adjusting this manually helped slightly. I’m provisioned with a 7Mbps upstream but in practice get closer to 7.3Mbps and FasTrack+ was guessing in/around the 3Mbps range.

After correcting the upstream speed performance still wasn’t as expected and only disabling FasTrack+ completely resulted in an acceptable connection.

My ISP offers my native IPV6 service, so I now went to the IPV6 page and added in my IPV6 PPPoE username/password (which is different then my standard V6 username/password). The connection came up and I was able to ping IPV6 addresses without issue, however, I couldn’t connect to anything. IPV4 connectivity seemed OK but IPV6 was limited to ICMP / UDP only and TCP connections just wouldn’t pass through the router in any form.

I tried rebooting the router.

When it came back up, IPV4 connectivity was working again, but even IPV6 ICMP was now down. Attempting to connect to the web interface produced the same problem was I had initially - while I could ping the router and IPV4 connectivity appeared to be working through the router itself, the web interface wouldn’t respond and was returning connection refused.

Out came the paperclip again and I 10-second reset the router. 

I repeated the configuration steps, double checking every setting (although I’m not sure what I had done at either time to cause the router to just stop responding to configuration requests). I verified that both PPPoE v4 and v6 were set to keep alive / always on.

Same issue with V6 ICMP working but no connectivity.

Rebooted router again - and again, and nothing I did could get it to respond.

Router is now back in it’s box and is returning to FutureShop.

Hope this helps someone who’s thinking of buying this product.  

1 Like

Thanks for sharing

Waiting to get mine and test as well

Don’t think your settings apply to everybody therefore not sure if issue was related to the settings

Did you by any chance try calling WD for assistance in this case?

Thanks for sharing.

I wanted to add my own, since getting to support was a pain (5 day wait on the e-mail, 30 minute wait in the call).

I too changed the default to non-standard which caused the device to stop receiving requests.  Restarting the device normally fixed the problem.

I also changed the password, which locked me out because…



My password was 16 characters, so entering just the first 15 let me in.

Also, I tried using the paperclip to reset to factory default, but wasn’t aware that you need to hold the thing for 10 seconds to get the full factory reset.  That would’ve been nice to know.

I was also having slow web-browsing (pages not loading, links from Facebook timing out, etc…) and also Skype was pretty much non-functional.  The support tech told me that my N900 with Fas Track Plus is geared for gaming, and that turning it off would drop the gaming prioritization but keep the media prioritization.  I think it’s probably BS but I’m giving it a try.  Speaking of disabling Fas Track, make sure you scroll ALLLLLLLLLLLL the way down to the bottom (past 31 empty rules) to click on Save.

I’m going to keep it, despite all.  I hope that helps someone in a similiar situation.

Try this for the slow web pages ,xbox live ,etc.

turn on fast track , auto classification , put user upload to 9999999999 kps , save , let it reboot , turn it on/off .

Web pages come up at the proper speed , logged back in , changed upload back to my real upload .

All my pc’s , phones work now !

really very odd , try it and see if it works .