My HDD my passport wont connect to my PS3

I recently bought a “WD My Passport 1TB” with intended use for my PS3.

When I plugged it into my PS3 it doesn’t seem to recognize the device.

When I listen closely to it I can hear the disk inside start to power up and then die down, when it starts to die down again you can hear a faint beep noise, it repeats this until I disconnect it. As far as I can tell its not a power issue because the LED light on hdd flashes the same when plugged into the PS3 and my computer. I have reformatted it to FAT32 using “Acronis True Image WD edition” which was suggested by Western Digital’s help support.

I have also read about removing the VCD from the hard drive. I tried removing it using “WD Smartware Virtual CD Manager” but when i run the program and it scans for a HDD it comes up with the error saying: 'No Device Found. Please connect a WD Smartware drive to continue; then click Rescan."

Does anyone have any ideas on how to fix this problem? Any help would be greatly appreciated.


Try to reformatting the drive again on FAT32 and see if it works

Im having the exact same issue. I have formatted it to fat32 for the last 12 hours over and over and my ps3 will not find it. Really starting to get pissed and about to just give up on upgrading my system. If anyone can help or anything please do.

Thanks for the advice but yes i have reformated it multiple times to FAT32 with a couple of different programs. I have tried both a logical and primary partition. but neither seems to work. i think its this VCD thing but, my HDD doesnt seem to have it. i think i may just have to sell it and buy a new one.

But if anyone else has any ideas they would be greatly appreciated. Thanks.

follow the instructions on the link please

Just a quick question: is the PS3 firmware update in the links method, the same as the PS3’s system updates?

I dont have a PS3 so i cant verify that if you want you can try to contact sony regarding the firmware update.

I did a bit of research andfound that yes the PS3 firmware in this tutorial, is the same as the PS3 system update.

So i followed the tutorial, but yet again i was unable to get it to display on my PS3.

i also tried wiping the disk of all partions which seems to have removed the VCD, but still cant get it to work with the PS3.

After reading other posts by people in similar situations, i believe that i may need a HUD power booster cable, so increase the power to the HDD. If after all of this it still doesnt work i think ill just have to sell it and look for something else.

Also try connecting drives with lower capacity to the ps3.

Finely Success.

After countless hour of research and re-formatting I finally got my HDD to work on my PS3.

For anyone who is having the same problem this is how you do it:

Making a ‘WD 1 TB My Passport’ work with your PS3.

Step1: Download and install “Acronis True Image WD edition” which can be found at


            Once installed launch the program, and run the “Acronis DriveCleanser” tool, this will erase everything off your

            HDD, so make sure to back it up first. (This step may not be required for everyone, but I did it it my HDD). I used

            the ‘fast’ option on my HDD when cleansing it but even still it took a couple of hour to complete.

Step2: Still using “Acronis True Image WD edition” add a new ‘disk’ to your HDD. This is where you will have to make

             ‘partitions’ on the drive (I divided my 1TB HDD into 2 separate drives, a FAT32 and a NTFS). When creating a

             new partition you will need to create a ‘FAT32 logical’ partition. This will allow the PS3 to read the drive. This will

            only take a few minutes.

Step3: Now the 'My Passport’s" problem is that it doesnt receive enough power from the PS3 when using the standard

            3.0 USB cable that the drive comes with so. You will need to get another, this is the one that i got and it works



           This cable will allow enough power to get to the HDD from the PS3 and intern it should allow the PS3 to display

           your HDD.

And that’s it, this is how i got my HDD to work on my PS3. But please note that I didnt install any of the software that the “WD 1TB My Passport” comes with, when I first got the device. This may effect peoples result, due to things like the VCD.

Are we saying that in effect it just comes down to a power issue due to the WD default chord then?

I’ve got the WD Elements 1TB Portable Hard Drive USB 3.0/2.0 - Black from Amazon, and it’s just not getting recognised by my PS3 at all.

It’s in FAT32 and I’ve had experience from a seagate i used to have. 

So is the deal with this cable that you plug one end into the HDD and for enough power BOTH USB connectors have to go in the PS3 - otherwise i don’t understand how a different cable provides more power?

As far as i know having the two USB cables does supply the HDD with extra power, when you have both USB cables plugged into the PS3. This is because its taking power from two USB ports instead of one. I tried it with the cable i bought from ebay, and if you put only one of the cable ends into the PS3 it has the same issue as if your using the cable that was supplied with the product. Im uncertian how this works, but it just does.