My hdd 3tb not work in WD tv live streaming

Hello i buy a hd 3 tb wd elements desktop and no work in wd tv live streaming, i formatt hd put in front and rear usb. I actualice to last version and rollback to 1.16 too and reset configuration and finally i no have more ideas because in my pc works fine. Anyone can i help me? 



The WD Elements drive is a desktop unit or a portable.

Can you provide us with the model number of the drive?

Is portable.

Number WDBAAU0030HBK-01

Legan wrote:

Is portable.


Number WDBAAU0030HBK-01

That’s a “Desktop Drive”

How and what Format did you use ?

(Supported formats for WDTV Live Streaming are FAT32 / NTFS and HFS+)

See also Troubleshooting USB Device in the user manual: Page 206

i format in NTFS, i use hd in other streaming media player and work fine (not wd tv live) and yes is a desktop i fail sorry.

Same problem here. I have the WDBAAU0030HBK-01 twice. They worked fine, but since last weekend (no firmwareupdates done the weekend) both wont work any more with the WD Live Streaming. The 1,5 TB HD still works. And all HD’s work fine on the Windows Computer… They are all formated in NTFS

Any solution?

Suggest you connect the drive to a windows computer and check the drive for errors. Windows Explorer>properties>tools>Check Now>automatically fix file system errors.

The drive may be flagged as “dirty” and need to have the flag reset by the Error check.  The WD can be picky about sure to “safely remove” the drive by the OS before unplugging.  In windows use either the “Safely remove hardware and eject media” in the applet bar. On the WDTV use the “Eject” button on the remote.


Chek hd in windows and now work fine thx!!

big thanks to Braumeister,

the HDD’s work fine now


thank brau… i had the same issue and it fixed it… kudos coming your way!!!

I am having the same problem, yet my hard drive says it’s fine and won’t let me re-scan it at all. Yet, it still doesn’t show up on my Media Streamer.

Please help.

anyone find a real solution to thie 3tb hard drive issue??

I even partitoned the drive to a 2tb and a 1tb, no luck at all - does not find it.


If formatting to NTFS and checking for file system errors does not work, you might wanna try a shorter/thicker USB cable.

I had the problem again. And I think it is Windows 8. Before I used Win7 and everythink worked well. Since Win8 I have the problems from time to time. Win8 tries to make auto-correct-error. When I try to chkdsk the HD I will always get an error. When I plug the HD to a Win7 Computer I can run chkdsk, it will correct the errors and everything is fine again. Maybe you should try it with Win7

I’m one Win 8.1 and I have no problems using my HDDs with it and the WDTV.