My Computer recognizes WD Smartware, but not the hard drive itself


#1

Recently I’ve been working on a movie in Final Cut, using my external hardrive to house all of my data and pretty much everything from my computer so I have enough space to run Final Cut. Recently, I ejected the hard drive from my computer, but accidently unplugged it before it was completely finished ejecting from the computer properly (my computer was running slower than usual with Final Cut). After that, my hard drive stopped showing up on my computer - the WD smartware shows up, and I can unlock my hardrive, but after that, the smartware doesn’t show an external device, and neither does my computer. I tried using the DIsk Utility on my Mac to diagnose and solve the problem, but nothing ever happened, and it couldn’t discover an issue.

I was wondering if anyone might know a way to solve this issue, or if my information is at the very least recoverable - all of my documents, music and video were on it for the duration of my editing process, and I would really like to get that back.

Thank you!

P.S. - I have a my passport essential, 1TB


#2

Have you tried unplug all power and data cables from the WD My Passport drive?

Power off your computer, turn it back on, then re-connect the WD My Passport drive?

Then go to Disk Utility to run the 

a. Verify Disk

b. Repair Disk.

Unplug all power and data cables from the WD My Passport drive, then

Power off your computer, turn it back on, then re-connect the WD My Passport drive.

Will the WD My Passport drive recognize?

If yes, you are done.

If not, reply with more info about your Mac computer, What OS you are running on? What kind of Mac you are using? Imac, MacBookPro or else?


#3

Mine was also unplugged wrong while moving my laptop the hard drive (my passport essential) dropped and disconnect from the cable/mac book pro. I did the things you have posted but it’s still not showing up, but wd smartware. after verifying and repairing it said unable to read FAT (input/output error) which I don’t know what that means. it also shows Mount point: not mounted. Please help I don’t want to lose all the memories of my niece and nephew since the day they were born. 


#4

If it was dropped it may be damaged. It doesn’t take much of a bump sometimes just tipping one over is enough.

Joe


#5

I just plugged my hard drive to my TV and I was able to view all my pictures and music. Do you know anyway that i can fix this problem so that I can view this on my comp since the files are still there. 


#6

There are couple of different issues here in this thread.

mewtaylor,

It’s possible that you corrupted your data when the drive was unplugged before completing the safe removal.  Safe removal makes sure to clear the cache in the drive, so that data doesn’t get corrupted.  Check disk management to see if the drive shows up there.  If it does, then you may want to look for some data recovery software that might restore files from a corrupted partition.  

xmimerzx

If you can view the files on your TV, but not on your PC, then you may be dealing with power issue.  Try the drive on other computers to see if it shows up.  Make sure your laptop is plugged in, itself.  If the drive shows up on some and not others, you will need to get a power booster cable from Tech Support.


#7

I started having problems with my 3 Studio LX drives a few weeks ago. First the free space indicators went blank and then the disks would not mount on the desktop (Mac Mini OS 10.6.5).

I followed the instructions on updating the firmware and software for the drives but I still have intermittent problems. I’ve tried switching cables, switching power cords, connecting to different computers (Macbook Pro, Mac Pro) and I keep having problems. One disk has stopped connecting even with the USB connection and the firmware updater doesn’t recognize that there is a connected disk at all. (Backed up fortunately.)

A symptom that I’m going to start having problems is that the WD smartware doesn’t recognize the disks. Or it recognizes the disk but won’t let me change the settings on the disk. The recent smartware update (12/9/2010) suggests others may also be having problems but the firmware hasn’t been updated since 5/20/2010. 

Currently all 3 of my disks are mounting with a Firewire connection but WD Smartware is only recognizing one and not letting me change the settings on any of them. Two disks show the Free space indicator and the third does not.

If you ask me, drives should just work.


#8

I am having the same problem as mewtaylor. But I thought I disconnected it the right way. But my Mac won’t even acknowledge that the drive is plugged in. The light comes on and I can tell the drive is on but nothing else. 

I just tried downloading the new firmware, and received an error that the drive could not be located. 


#9

I too am just experiencing this incredibly aggravating experience.  I just purchased two WD drives after having a Seagate crash.  After 12 months of use, accidental unplug of USB data cable has rendered my 1 TB My Book garbage.  Computer doesn’t recognize and now I have to spend time and money AGAIN to recover data.  I would think in this day and age it certainly must be possible to create a product that is not so precarious.  This is, after all, your business isn’t it? Isn’t this in part what you do as an external drive company - to help people save important files from freak accidents?  I feel FAR safer having data on my main computer drive.  Your products seem far more dangerous when an accidental unplug of any kind, USB or power, can send the whole thing crashing down.  Absolute BS.