My computer rarely recognizes the 4 TB WD Black HDD

Hello all,

I recently bought a new WD 4TB black HDD from ebay a few weeks ago, and my computer is rarely able to recognize it. My mobo is a Gigabyte 97X-UD5H. When I first installed it, it didn’t show up, but when I rebooted it, it did - I was able to go to disk management to add the letter drive and mount it to my PC. I believe it did an update afterwards. It then didn’t showed up. I think over the course of it being in my PC, it only showed up 3-4 times total.

I did everything from buying new SATA cables from Ebay despite that the SATA cable I’ve owned were new to begin with. I even made sure the cables weren’t loose and switched the SATA ports around. Still, nothing. I am thinking of getting a support ticket for this HDD, but I am wondering if it has something to do with Windows 10 not being able to recognize it.

Any help would be appreciated. Thank you all.


It may be an issue with the drive itself. Have you tried on another computer?

No, not yet, though my father wants it as he thinks it is an issue with Windows 10 not recognizing drives over 4TB. I can easily test it out on his computers as he lives close by to me. I will test it out.

Since it was new, would I able to send it to WD for a replacement if I were to create a ticket? Thanks.


If you wish to get the drive replaced, WD will replace it without any issues.


What model number is it? I am looking at the spec table right now for WD Black drives, because I just had the same thought. I also want the 4 TB model. Then I came across this post.

I also think Windows 10 has issues with drives. It may have screwed up my WD Red 4 TB. That’s why I’m looking at WD Black now as a replacement. It did some funny “repairing” at the end of the upgrade process from Windows 8.1 to Windows 10. This system has many issues in general.

I will test my WD Red 4 TB on Windows 7 shortly and then Linux. But I also want a replacement ready at hand. So please report back about your WD Black issue.

I too think Windows 10 screwed up my hard drive because I’ve noticed that when it didn’t work, it was due to a windows update. When I had the HDD in my computer, Windows kept wanting to update, which I let. However, sometimes the update would result in a windows 10 error even though during a reboot update. Now that my 4tb isn’t in my pc, Windows stopped with the restart and update dialogue box.

My model is WD4003FZEX

As for follow up, my father tested it tonight and his PC recognize the HDD (a disk error popped up), but couldn’t format it as the drive didn’t show up on his pc. He is going to test the drive until Friday, and if it still doesn’t work, I am going to ask for a replacement.

I posted a question earlier about the WD Black 4 TB but no one has answered yet. There are actually two models. One is the WD4003FZEX and the other is WD4001FAEX. I take it that FZEX are the new revisions. So I would expect the latest and the grates to work the best with new products such as the new Windows 10 system. But apparently not.

I have the WD Red 4 TB for NAS, but I use it for storage in a desktop. I am in the process of backing up everything I can off of it. Previously it was barely putting out 2 MB/s continuous read speed, when it should be at least 120 MB/s. It can go faster but my hardware is old so I’m using a SATA2 controller instead of SATA3. But it worked all good on Windows 8.1 for me. Then I upgraded to Windows 10 and it did some funny “scanning and repairing” stuff at the end. I believe it means it was running a CHKDSK command on the disk. After that, my drive has not been the same.

Oh yeah… I almost forgot… the CHKDSK command… this “scanning and repairing” thing… it corrupted my only copy of a local database file in which I keep all my passwords that I have been collecting over the years. Over 200 passwords, and many other important data was in it. All gone! Only an empty 0 byte file was left in place. What’s also interesting is that every other file was OK on that same drive, all except the most important one. I know, I should have had an external backup. I had a copy, but it’s a much older version. Few days later, I managed to actually recover everything by scavenging the raw data from the disk. I was lucky this time. But I will never trust Windows 10 again. It had no business touching my storage disk as itself was being installed on a Samsung SSD disk.

I have the drive connected to another desktop PC, also running Windows 10, and it too was upgraded from Windows 8.1. As soon as I booted up I saw the warning text that Windows is preparing to run a disk scan. I wasn’t fast enough to abort it… again! Same thing happened the last time. I wish this would not kick in automatically. I would prefer to have it only scan the disk and then ask me what to do next… I think I know my computer better than Microsoft and better than Windows 10 does. I know when there is something wrong with it. I know this drive was fine before. But the drive is reading at the normal 125 MB/s speed now again in the other computer. That’s reason enough for me to celebrate. Otherwise it would take me many days to back it up completely at only 1 MB/s.

I will go back to using Windows 7 again as soon as I am done with all this agony Windows 10 is putting me through. But before I do that, I will do a long disk test, then a zero fill and then the partitioning, and then a quick format. So I have a ton of work to do thanks to Windows 10. Not to mention finally getting down to it and restoring access to my Microsoft account using the recovered password from raw disk data.

Windows 10 is… a nice idea! That’s all it will be for the coming two to three years or so until they finally come down to it and realize all the crazy changes they are pushing for with this OS. It’s only good on paper and slideshows.

If it’s a viable option for you I suggest you get rid of Windows 10. Even Windows 8, especially Windows 8.1 is much better by comparison. Windows 10 is a testing platform for Microsoft. They do the experiments and we pay the price. It’s not fair. Why use something like that if you can do better?

In your case, if you haven’t used your drive at all, and haven’t saved anything on it yet, I suggest you do an extended test on it to see if it checks out OK. You can do the test on your father’s PC if you can’t get it recognized on yours. Use the WD DLGDIAG program for Windows. If it fails the test, backup any data from it and send it back. If it checks out OK, but you can’t see it in your PC, send it back. It may not be compatible with your PC for some bizarre reason.

Do you see the drive under BIOS/UEFI? What kind of partitioning and filesystems do you use? The disk format should be GPT for volumes over 2 TB to work properly. But I would recommend using GPT on a 4 TB drive, even if you make each partition on it much less than that, like four partitions of 1 TB each. Especially if you work with a UEFI system. GPT and UEFI goes hand in hand. So it’s recommended to use GPT whenever you can for best compatibility.