My Cloud - solid white LED

I’ve owned a first generation My Cloud (single disk) for years and it has been plugged into my router with a fixed IP of without many issues for all that time.

We had a power cut last night.

Before the power cut the NAS was accessible, afterwards it is not. The power came back on and the front LED on the device remains a solid white - it never goes blue.

I believe that this means the device has begun its startup - but it never changes. I have left it overnight and it remains a solid white this morning.

The device does not appear in the router’s list of connected devices.

The LAN port on the back of the My Cloud only has a single flashing green LED indicating activity. The other LED is not on - I believe that indicates no link has been established.

This morning I have also tried a power cycle of the device without having any LAN cable plugged in. I wanted to check if the LED eventually changed to blinking amber - which should indicate a network cable is not plugged in - but it doesn’t. Nor is there a solid red light, indicating a fault, either.

The My Cloud front LED remains a solid white all the time.

The green LED on the LAN port indicating an established link is not lit at any time except for about 8 seconds or so after power cable is inserted, then it goes off and only the activity LED flashes. I have tried a different port at the router side, and a switch.

I have tried to press the recessed reset switch for 5 seconds - nothing appeared to happen.

Can anyone recommend next steps? My objective would be to have access to the data.

I have just attempted the 40-second reset… removing power, holding the recessed button down for 40 seconds while power is restored. Still a solid white light and no indication that anything is going on.

Check the network router or gateway administration page to see if it indicates the My Cloud obtaining an IP address.

If the network router/gateway indicates the My Cloud is connected to the local network try accessing the My Cloud Dashboard.

Single-Bay My Cloud OS 3 Dashboard Access

It is also possible the My Cloud is scanning and fixing drive issues or indexing the drive after being powered on that may result in the My Cloud not showing a front blue LED. Sometimes that drive check/index could take a considerable amount of time (hours to a day depending on # of files and drive capacity).

Thanks. Yeah, I’ve already confirmed there’s no IP address being assigned to it - my suspicion has been all along that, somehow, the network interface got fried.

The single flashing LED on the LAN port was the biggest clue. I don’t know that for sure, but no 4 second or 40 second reset seems to do anything in that regard.

I’ve moved beyond this stage in the last hour… I’ve ordered a 2-bay QNAP from Amazon and some disks - it’s time to retire this poor WD darling, I don’t mind - she’s served me very well for years, but I think the best strategy going forward is some kind of mirrored setup with easily removable disks.

But first - can I access the data on this disk?

Well, I’ve broken the disk out of its WD casing… and plugged it into a Windows 7 PC via a UGREEN USB IDE/SATA gadget… it could have been hit-or-miss.

But the drive, when given power, starts and Windows has shown up drive letters of D:, E:, F:, G:, H: and I: - they are all an unrecognised file system - no surprise there.

Next steps… as I don’t have Linux… will be to grab some utility to allow Windows to ‘see’ the data, yes?

If you have any advice, I’ll be grateful.

I saw someone else comment that the disk inside one of these isn’t a WD Red - but mine definitely is.

Using Paragon’s Linux File Systems for Windows trial software… managed to mount L: and see a folder called shares which seems to contain all my data. Copying over now…

For future knowledge you could have created a Linux boot disc or boot flash drive to boot the computer with to access the extracted My Cloud Hard Drive. Most people found WD Red’s within their older single bay My Clouds.

Example of how to create a bootable Linux distro on a DVD or USB flash drive:

Here is the User Manual. You need to look at chapter two LEDs. Did you have it set up for use on your home network only?

I’ve kinda moved on, now… it was definitely never getting an IP address, no matter what I did. The case is in bits on the floor… the disk has been removed and plugged into a USB gizmo and I’ve moved the data to two USB disks in preparation for when my QNAP basic model arrives. I feel OK, now, as I have no NAS, but I do have the data across physical devices. I’ve depended on the My Cloud doing its thing for too long - time to bite the bullet and try and do things more properly from now on.