My Cloud Set-Up on iMac

BoughtMy Cloud last Thursday and tried to set it up the following day. Set Up can’t see the device. Registered a case with Support [Deleted - Privacy] I then rang support and spoke with an agent. Who talked me through everything I had already dome, including directly connecting the device to the iMac, bypassing the router. Still no joy. The agent said he would escalate my problem. (Four business days later and no response from the support at WD).

I took delivery of a new Macbook Pro at the weekend. It’s running the same OS x Yosemite as the iMac yet it sees the My Cloud device, over Wifi, and I’ve set the device up and upgraded to OS 3. My iMac still can’t connect to the device. The problem is that ALL my photos and files gets are on the iMac, which will remain key to my network at home. I will have a continuing need tor the device to connect to this computer. Can someone help me please. WD support don’t appear to want to know. Thanks/

What have you tried so far? Did you attempt to manually map your network drive?

Hi, I have been contacted by WD Support, who spent quite some time on the phone with me to try and resolve the problem. We ended the session with an assumption that there may be something wrong with the iMac. I contacted Apple Support who very quickly confirmed that my issue was due to me (stupidly) running a third party antivirus in the background. Why do we always look for complicated issues when it’s usually something simple that gets over looked? Once I uninstalled that program the WD device works correctly. Thanks for your help and thanks to WD Support for getting back to me. Cheers.