My Cloud OS5

Has anyone tried the new app version above on Andriod to see if it screws up the videos not backing up and not backing photos issues we had with the last version.
Im afraid to update and try the new version incase it all goes wrong again.

I’m about to try it out since I just noticed your topic. I’ll post another reply later after I give it a try.

1 Like

Let us know how it goes and if you loose any of the locations for backing up from or any other functions.

It’s still the same, it shows it is synchronizing, but never completes it.

1 Like

Wow thats shocking. At least you can roll back to version
Thanks for letting us know.


I just finished uploading all my photos and videos. I changed the backup location from one of my shares to the Public share. They all uploaded.

I took a photo and it has been backed up. I’ll wait and see if it continues to work.

Interesting. I might give it a try. Can always go back to the old version.

I now have my camera photos and videos in both my Horace share and my public share. Today I decided to back up my camera pictures and videos onto my Horace share and it actual showed them syncing to Horace. After that finished I changed my backup to go to my Public share again. After rebooting my router and my desktop computer, my weekly reboot, I decided to look at my My Cloud again and both locations now show my pictures and videos. See image below. Click on, tap, or activate image to enlarge it.

This update still doesnt work for me. It sits "“syncing” for hours but not actually doing anything or sits with a random number of items left for syncing but doesnt do anything. I thought it had worked but then it sat with 1 item remaining for hours. It then went back to the usual " connecting " or “preparing back up” for hours but actually do nothing.
Im staying with