My Cloud not on LAN device list after router change - Issue Resolved

I have read through many of the topics on this board and tried suggestions without success. Here’s my scenario: I have been happily using my My Cloud personal storage device (I’ll call it “Cloud PCS” here on out) for almost a year from within my home network through 2 PCs both running Windows 10, and accessing it remotely outside my network via the My Cloud webpage signin. Last week we replaced our AT&T router and successfully set up the new network and connected all our devices either through ethernet or wi-fi except for the Cloud PCS. It is not visible on the network. The Cloud PCS is connected by ethernet cable to a Linksys ethernet switch which in turn is connected by ethernet cable to the AT&T router/gateway. This is the way it was previously configured with the old router and everything worked fine. What we have done to troubleshoot:

  1. Rebooted the router and checked our LAN home page to see if the Cloud PCS was on the network (it was not). Looked through the list for the MAC address of the device - it was not there.
  2. Did the 4 second reset on the Cloud PCS and checked the list again - not there.
  3. Did the 40 second reset and checked again - not there.
  4. Powered down the Cloud PCS and disconnected it from the switch box, intending to try connecting it directly to my Windows PC by USB, but I read on the WD knowledge base that it was not possible to do that, so I reconnected the device to the switch box as before and powered it back up.

I understand the concept of assigning an IP to the device so it can be found but I can’t do that if I can’t even access the dashboard or see the device anywhere on the network either by IP, MAC or Device name.

Any help is appreciated. We have image files stored on this device that we don’t want to lose. Thank you.

This might help. There is a program called wake on lan. It can be downloaded from the following site.
http://www.nirsoft.net/utils/wake_on_lan.html

When you run this program it will list all of the devices it sees on the network. It gives the IP address along with the mac address.

It is possible to plug the MyCloud directly into the networking port of a PC afaik to directly access the data at least.

Thank you. I will give this a try this evening after work and report back.

I was afraid to try it after reading the notes on the WD website but I was thinking of connecting with usb. Are you suggesting I temporarily unplug the Ethernet connection on my PC and use that port to plug in the cloud device? I can give that a try if at least we can get the data off of it and then maybe do a factory reset. I will try tonight. Thanks.

Yes. See the Appendices in the User Manual.

Before you do that, though, tell us what the LEDs on the device are indicating:

front panel LED
ethernet port LEDs

If the front panel is flashing yellow or red, it probably means it has a problem finding the network.
If the ethernet port LEDs are both off, it probably means your unit is unable to connect to your AT&T router (even via a switch). AT&T-supplied routers are well-known for being incompatible with MyCloud (search the forum for Uverse).

Try different ethernet cables.
Try a different router port.
Try a different switch port.
Try connecting an accessing PC via the switch. Can you see anything attached to the switch in the router’s device table?

3 Likes

Front panel LED = solid Blue
Ethernet port LEDs - Top = periodic flashing Green, Bottom = solid Green
Linksys Switch Ethernet port = solid Green

I changed the switch ports with the same results.

Then I changed out the Ethernet cable between the Switch and Router and success!

I am glad it was something simple, but I am a strong advocate of taking a methodical approach to troubleshooting. I sincerely appreciate the suggestions and support.

Thanks!

@keyphan
What was the make and model of the old router?
What is the make and model of the new router?
What is the model of the “Linksys ethernet switch” ?
What is the firmware version of your My Cloud?

Problem is already sorted…