My Cloud Login failed 504 Gateway Time-out error

Why the My Cloud OS3 status is not updated ?

https://status.mycloud.com/os3

Anyone heard anymore updates? We still can’t get in!

try to clean your cache

We have been able to get in remotely today, from all our second office machines and mobile devices.

Still the same here, can’t get in to view files. Can get in as admin but says firmware is up to date.

How are you all doing with the troubleshooting. I’m now getting this. I followed the instructions but no change.

Same old, same old :confused:

This is 2 Days now … and they will not update the server status page do they think we are idiots…I am lucky that i can use team viewer to access my drives when this Shi**y service is down.

48hrs in and still no fix?

I spoke to support who suggested a System Reset. We did that yesterday and no I can’t even get in to the MyCloud SetUP. Need this resolved ASAP!

It’s not working again (it worked for a while), no support number in Italy, I’m totally going to move to another service!

Here is the support number for Italy according the WD’s website.
Italy : 00800-27549338

https://www.westerndigital.com/support/international-numbers-hdd

Same here, I was about to reset my device…They should update the server status page.

This was me a couple of days ago. Bennor assisted me with some instructions. [quote=“JoeRandyTX, post:4, topic:248113”]


[/quote]

MyCloud.com is working on my end.

If you haven’t done so already turn off Cloud Access/Remote Access in the My Cloud Dashboard > Settings. Wait a few minutes. Then re-enable the option and wait for it to indicate it’s connected. Or try changing the setting for Cloud Access to Manual and use alternate ports (like 8080 and 4443) then port forward those ports through the router firewall to the My Cloud.

liked this

This was my result only on PC. On mobile app it is still not working.

same issue in KSA

72hrs in and still no fix and no update in relation to the progress of the issue. :frowning:

This is getting ridiculous - we haven’t had access all week!

This is unacceptable, we just had the Service Unavailable error since last Friday and now this error for the last 48 hours. We’re coming up on a full week of 30+ employees being unable to access files that they need to in the field. This is not the first time this has happened either. There was a similar situation a couple of months ago. If WD doesn’t get their act together we are finding another service, we can’t rely on this.