My Cloud Login failed 504 Gateway Time-out error

It’s doing the same thing on Safari.

Nothing to add other than I am down as well, just getting the blank screen. I did manage to get the login page to show for a moment, but was kicked out once when trying to login and the second attempt I got a 504 Gateway Time-out error.

Attempts to login were tried via Chrome, Safari, Firefox, and Firefox Developer Edition.

I have managed to get in as adim by powering off system & powering back on but still can’t get in to view files

  • Failed to update device user. (400068) connection failed Cannot establish remote access connection. Make sure you are connected to the internet.

Spoke to tech support and they are aware of the server issue. They did not give me an timeframe on when it would be fixed.

The same problem:

WD used to sell bunch of hard drives - until someone there decided to expand the business and keep shareholders happier - who cares about customers!!

Remember, there’s a reason IoS twitter account is so popular!!

Same for me

Same here :confused: Now the android app is broken as well in my case :confused: This is so ■■■■■■ up, that they have always problems with this nightmare My Cloud

Same here, unable to access My Cloud via mobile or Web Browsers. I’m getting the " 504 Gateway Time-out" on my PC browsers. On my mobile it says, “No network available”.

1 Like

24hrs in and still no fix! The log in screen however now says to check for updates but none available :frowning:

1 Like

Android app still works but I’m not logging out just in case I can’t get back in!

2 Likes

Exactly the same problem. But my android app worked today early morning, now it’s just REMOTE ACCESS DISABLED (970) error ;/

1 Like

Guys it’s working now!

Still not for me! :frowning:

Why the My Cloud OS3 status is not updated ?

https://status.mycloud.com/os3

Anyone heard anymore updates? We still can’t get in!

try to clean your cache

We have been able to get in remotely today, from all our second office machines and mobile devices.

Still the same here, can’t get in to view files. Can get in as admin but says firmware is up to date.