My Cloud indicates offline - Nighthawk router can see the device -

Hello All,

Last night I noticed my My Cloud NAS showed offline. I don’t know this is, and I have spent all day trying to fix this problem. It is beyond frustrating.

My nighthawk router can see the mac address of the device and is giving it an IP address.
I have enabled UPnP - no devices are showing though in that area

I read that you can port forward to TCP 443 though the issue is that there is no TCP option, HTTP, FTP, Telnet, VPN etc; no TCP and be listed.

I have all IPs as DHCP the entire range and data shows up in the log that it is activated
I do have Access Controls enabled - All IPS are allowed
It shows connected to the router though the app, nor the MyCloud website can connect - indicating it is offline.

I am not sure if this is a device issue, though could be - it might be a network issue.

I am on MacOS - monterey still - going to upgrade that in a second to see if there is an issue with that - though doubt it.

Anybody have suggestions for me? I am stuck.

Armor trial was activated by someone - and that could have been an issue - had to rebuy it to disable it - no dice - still not showing up online.

What specific My Cloud model do you have? And what firmware version is it running? The firmware version is listed on the My Cloud Dashboard.

Hello Bennor,

Good questions - It’s the My Cloud Home Personal Cloud unit and I can’t get to the dashboard at all. I can ping the unit and the device is being recognized on the network; though the app doesn’t see it; indicating it is offline.

PING ( 56 data bytes

64 bytes from icmp_seq=0 ttl=64 time=1.949 ms

64 bytes from icmp_seq=1 ttl=64 time=2.101 ms

Does your device look like this:

If so, the My Cloud Home is a completely different device than the My Cloud line of devices. It does not have the My Cloud Dashboard. It does not use OS5 firmware. The My Cloud Home uses a different operating system and has different features/options than the My Cloud line. You may want to move your post discussion (by editing your initial post) to the dedicated My Cloud Home subforum or start a new post in that dedicated subforum where users more familiar with that device may be able to assist.

My Cloud Home

The following WD Knowledge Base Article for the My Cloud Home may be relevent to your issue:

WD My Cloud Home Not Detected, Not Found, Cannot Connect or Device Offline

More My Cloud Home support articles can be found by searching the WD Knowledge Base:

1 Like

Thanks -I will do my best to NOT ever buy one of these again. Sad thing is that I have G Drives too - owned by the same company. Really frustrating that this just happened. The device is just about 3 years old. With NO way to recover any of your data without taking apart the device.

Oddly enough, all of the sudden last week I’m having the EXACT same issue with my EX4100 (4X 18TB). My router sees the unit but everything displays as “offline.”

Oddly too, recently the power button on the unit will do nothing. The screen also shows “Power Failure on Port One” (or 2) depending on which power port I plug into. Very frustrating!

I have been trying to figure this out now for about 20 hours.

I might be tearing this thing down, trying to salvage my drive and get rid of ALL my other WD devices. Heck, I even have G drives too and these guys bought them. So, I think I might be investing into another system.

I will be calling WD tech support at 11 EST - since they open at 8AM PST today; though based on what others have posted on here, I have little faith that WD support can do anything.

Good luck. I wish I could help you. If I do come across a solution, I will for sure post it. I have read so many on here- nothing is for sure - though I have gone through multiple cycling up and down my network devices, powering off to on - it looks like the OS that the DUO runs out crapped out with the latest update perhaps.

I’ve done the same and I’m afraid if it were a software/firmware issue these forums would have a lot more to offer.

Looks like a warranty RMA for the housing for me. It’s truly been a great device. WD does produce quality products. Been with them since the beginning. Good luck and post back if you learn anymore.

Called support - useless - it looks like the device is freaking bricked - so, I am going to take the device apart and do a recovery on it to get my data - THIS IS NOT MEANT FOR BACKING UP! NOT ONE BIT.


They lost a customer - I have G Drives, My Cloud, MyBook and this other bad device . Might have to move to LACIE or something else. Any suggestions will be appreciated.

What is the front LED on the My Cloud Home indicating?

Have you tried a reset?

What Does a Blinking Front LED Mean for WD My Cloud Home?

My Cloud Home: Pin Reset Button

Have you read through and or searched (via the forum search - magnifying glass icon top right) through the My Cloud Home subforum to see if there are similar posts to your issue?


We have reached out to you via direct message, so we request you kindly check and reply to your DMs so that we can assist you further.

We sent you a message with our incident report… so you want us to create another one?

The drive is completely unsalvageable. We just got the news from the company we contracted. See below:

Per our engineers, the platter surface is damaged to a point where any replacement
head disk assembly is damaged within an instant, making it impossible to read out any
areas of the platters.

We understand your disappointment and are sorry that we were unable to help.

Needless to say we are beyond saddened and bummed. Years of footage gone and edits the relied on that footage.