My Cloud Home - Lost acess to local folder after power faillure

Hello Everyone.
After power failure of my my cloud home, i lose my local folder, with all my files.
I hace acess to the public and time machine folder, but not my local folder.
I have tried to enter by the root, but the error is that the credentials are incorrect, trying to verify if the local acess its on or off. I have tried to entrer with the browser and theres an error saying that the dirve can not be finde, and ask me to introduce the my cloud home codes, as if was installing from the beggining.
Any one can help, or has the same problem? Thanks and regards

Do you really have a My Cloud Home (White top half, silver bottom half)?

Because no owner of the MCH can ‘enter by the root’, that is usually somebody using the older ‘My Cloud’. My Cloud series has a completely different CPU, memory, firmware and OS than the My Cloud Home.


Yes. Usually i open it when my computer is in the same network as shared folder. If i open the my cloud home i have acess to the folders. Public, time machine and my own.


I would suggest you

  • Check your router for UPnP and
  • Do a reboot of the MCH ( a 4 second pin reset)
  • Check for MCH access through a different browser or use the incognito mode of the browser

A Pin Reset 4 second reboot is better than pulling the power plug which can damage the sectors on the hard disk because the Pin Reset Reboot will tell the MCH OS to shut down and restart.

You can repeat the 4 second Pin Reset a few times to see if the OS can recover any file system damage on the hard disk. Allow the file system to recover for at least 15 minutes to half hour before trying to reboot again.

You should also start to file a support ticket or chat with WD Tech support.

The Pin Reset Button is on the backup of the My Cloud Home above the USB port(s). Use something like the pointy end of a paper clip to press the reset button. There are three functions of the button.

  • Reboot (1 to 29 seconds press)
  • Demote Device Owner (30 to 50 seconds press)
  • System Erase (60 seconds or until the LED Blinks and power off press)

Reboot (1 to 29 seconds)

The My Cloud Home will reboot making it offline until the process is done.
A reboot does not delete data.

Hello NoPlex.
Thanks I will try and let you know.

Hi! I have the same issue. Locally, I can’t access my files anymore. However, they are still available on web and mobile app. When trying to connect to my local network address like my username doesn’t exist. I too only have Public and TimeMachine folders available.

Tried all suggestions from above, but nothing helped. Still no local network access to my user folder. Any new ideas?

EDIT: This solved the issue for me How to Clear Device Settings on My Cloud Home and ibi

The original poster @NAPP cannnot access his MCH through the browser as if the MCH could not be found and authenticated by the web (browser) app.

It is not possible to access the ‘Clear Device Settings’ web app function if the MCH could not be found 'LOCALLY" and authenticated online.

This is why it is important to allow the router to have UPnP feature turned ON, at least initially, to allow the MCH a chance to identify itself as a local connection to the router as well as to the web app.

@NAPP could try to enter the IP address directly into the browser, for example assuming his IP for the MCH is this:


and see if he could get to the My Cloud Home Dashboard.