My Cloud Home is not visible on app or network since I moved

Good afternoon everyone,

I am asking for help as a “newish” user of My cloud Home!

I purchased a MyCloud Home a few months ago. I set it up without problem. Everything worked well and I could access my data as I pleased.

I moved countries a few weeks back. I recently connected my device (through ethernet cable) to the router in my new place (it is a rental and I don’t have control over the route). I can’t access the device and I don’t see it on my network.

I have tried setting up the device again by searching it on the network, couldn’t find it. It is connected to the router and the white light is showing, but nothing more. The only thing notable is that when I reboot it, it beeps several time on start (mechanical sound), though I don’t remember if it was the case before…

Is this a common issue ? The device is six months old at most. I couldn’t find any topics related on the forum

Thank you in advance for your help if you have any idea on how to resolve this issue.


Hi GB26,

The WD My Cloud Home device contains internal drive which makes noise during operation as these drives have moving parts inside them.