My cloud home Duo-- Very slow in the Network

Hello, my my cloud home duo with 16 TB in Jbod is in the last time very slow.

Only 18MB/s. Before I had over 70 MB/s .

Where is my mistake?

I have the app WD discovery and when I want to transfer big files, I only reach 18 MB/s.

I have all gigabit cable and now my cloud home duo is running in Jbod.

I tried to close all Media servers and apps running on it, but it is still the same.

Thx for your replies…

1 Like

Hi murat1981,

You can refer to the link mentioned below in order to resolve you issue.

hi, have you solved this problem? I am in the same situration as you were.

Same issue listed here apparently:

Since when did you notice it?

Are you talking about the user private space or the public share?

Those tips simply don’t work.
Nothing has changed in my network or how I use the device.
It slowed down on its own out of the blue.
This is for sure related to a firmware update.
You should really be digging deep into this.
As it happens to more than one device in the exact same way, it is obvious that there is something wrong with the firmware.

@SomeoneInTheFarm @bearyoung @murat1981 what country are you located in?

Hello, I think the mistake lies in that router what I have. I realized it when I plugged out the cable from the ISP. Then I had again 75 MB/s.

Thank you for your input. Im also a user of “My cloud home”, and was experiencing low transfer rates about 16-17MB/s on cable GB-network, so not OK.

I think the low transfer rate has something to do with remote syncronization. Thats why you were back at 75MB/s when disconnecting ISP.

The intermediate solution is as you say: temporarily disconnect your ISP-cable/connection before making large data transfers and they will be done with Good/OK speed in par with read speed of the hard drive (in my case about 110MB/s). After transfer is done you can re-connect ISP.

Surely this must be firmware-related so please WD look into this!

For everyone who would stuck with that, I found a solution, thanks to @murat1981 .

Short answer would be - re-plug the LAN cable on device. It would re-initialize device inner state, as I understood, and it’s back to normal speeds.

After I plugged out my My Cloud Home 8TB single bay device from switch, plugged it back again, it reinitialized network connection, and now kdd speeds is back to normal.

I’m on Win10 64-bit. Short-way-to-MyCloudHome in my network is:
PC_LAN - UTPCat5E (about 5 meters long) - D-Link-DGS-1210-28/ME - UTPCat5E (about 2 meters long) - MyCloudHome
I plugged out and plugged in the MyCloudHome cable from D-Link side.
Also, I had a look at web-interface, and had a look at switch indicator for port before re-plugging the cable. Both reported that MyCloudHome link speed is “1000M Full” (indicator was green, and port status in switch web-interface also reported as “1000M Full”).

Dear WDStaff, I had download debug logs from my MyCloudHome device after I re-plugged my device to switch and seen improvement in transfer speeds and kdd-process-improvement, could it be useful for you to investigate the issue?

Now I am waiting till it would break again…

Also, I had a quick search on debug logs, and can’t say actually, if there is some reporting of link speed which device got from network.
I had a look with words “speed” and “link”.
“speed” finds a lot of “ffmpegwrapper” output in main logs
“link” finds a lot of “ConnectivityService: checking ethernet link” lines in main logs
both would find a lot of IDs with that words in different cases :slight_smile:

Is there a keyword which I could use to search for link speed which device got on eth?

Hello me again, I have still difficulties with my connection speed. I think the WD Discovery App have still some bugs to fix.

I changed my router and tried also with another router but the same… Still 18 MB/ s . The only way to fix is still plug in and out the cable.

Dear WD Stuff I think there is a bug in the software since approxiamately 3 month. Before there was no problem.

I am not the only one who have problems with the speed and also with WD Discovery. I have the newest version on my machine and it has sure bugs in the software.

Please fix it.




Today I was capped at ~200 mbps.
I tried to pull out cable from switch, but that didn’t help.
The only thing which helped to get back gigabit speeds was to reboot MCH from settings panel at WD site ( My Cloud Home )