My Cloud Home Duo - can't get "local connection" on

Hi, I got myself My Cloud Home Duo and I can’t get it run on “local” in connection type.

  • The unit is connected directly to the same router, as my computer (both with cable, or wi-fi).
  • The router is Archer C80, UPnP is on
  • My Cloud is visible as device for the router, but is not in UPnP list devices (not sure if it needs to be listed there)
  • I tried connect to My Cloud by entering IP address (192.168…/static/login), it shows page with login. But when I fill username and password, an error message shows up.
  • Mobile app shows it is connected locally, but there is no “manage device” option.
  • I tried turn antivirus and firewall off, still not working.

Can someone help?
Thank you, Vojta

You may need a different router. Western Digital Tech support does not support troubleshooting router connectivity since there are hundreds of different routers in the world.

Just because a router stated that UPnP is on doesn’t mean it is UPnP compatible with clients such as the MCHD. There is a detailed thread on the C80 dropping UPnP clients on the TPLink forum:

Re:C80 UPnP not accepting clients (other routers work fine)

@Kevin_Zam currently on Archer C80(US)_V1 200907 as I am in the US. I tried the EU version Archer C80(EU)_V1_201003 temporarily but it did not work. 201003 is not available in the US version.

Does this mean you need to re-add the ports on the C80 to make the game console work?

Yes. I added the port forwards to the router and it worked for a few hours. Then overnight they mysteriously stopped working. I had to remove them and re-add them to start working again.

I have attached the network diagram below. Please note there are only two people in the house so we’re only using two devices at a time.

1 Like

Thank you, NoPlex, for quick answer.

To troubleshoot this issue, I’ve bought 2 routers :smiling_face_with_tear:: 1) Xiaomi Mi Router 4A 2) Mercurysys MW301R.
I’ve connected just laptop and MCHD (both with cable) and a phone (by wi-fi) to the same router. Both routers have UPnP on.

Still same result as with archer C80: phone is in “local” connection and laptop in “relay”.

Is there something else, what could be problem?
Thank you.

I am going to guess your ISP is blocking the ports used by MCHD, but the mobile phone has some VPN running that is bypassing the block. Use an online port checker to see if the ports required by MCHD is blocked or just ask your ISP provider.

1 Like

Wow, I’ve never checked ports like this, thanks for tip.
I clicked on every link in “Check port” (via

I assume, that this information means, that port 443 is not blocked, am I right? Same information i get for every port (8001, 4430, 8003, 443 and 8443)

And I forgot to mention another piece of the puzzle:
On the phone, the connection is “local” only in the MCHD app. When I open MCHD management via a web browser, the connection is also “relay”.

I think the puzzle is your ISP or your country or region not supported by Western Digital.

It is difficult to troubleshoot someone’s network set up all around the world, that is why WD Tech support does not go through each router individually and not for each ISP and country.

Check that you are not behind another router in a double NAT situation and that your country is not in a sanctioned region of the world such that WD cannot provide relay servers to your region.

Network Configuration - Double NAT
Use the chart below to ensure your ibi network environment is configured with the BEST CONNECTION and not the NOT RECOMMENDED - DOUBLE NAT configuration.

  • Wireless 802.11 AC or N Network Router connected to the Internet
  • Your ibi directly connected to the Wireless 802.11 AC or N Network router and not behind two routers in a Double NAT configuration.

“Double-NAT” is when you have 2 devices on the network, both handling Network Address Translation (NAT) services and or serving DHCP addresses at two levels. The most common is having an a third party WiFi router plugged into a Cable Modem/Router from your Internet service provider.

1 Like

Thank you very much for all your efforts.
I strongly believe that I am not in a sanctioned area (Czech Republic) and I was connecting the router directly to our internet source, not through another router.

I think you’ve put in enough effort and MCHD is probably not for me. Thanks again for your effort.

If anyone from WD is reading this, I would recommend:

  1. enable device management in the phone app
  2. support the windows desktop application again